Hardware & Build Advice
Hardware & Build Advice
cancel
Showing results for 
Search instead for 
Did you mean: 

Forum Posts

Need help with new build

hi to all. i need help with my new build. however i have limited options due to market. i can choose from few components available in my country. these i can chose from ASUS ROG Strix X570-E GamingASUS ROG Strix X570-F GamingASUS ROG CROSSHAIR VII HE...

cimbri by Level 9
  • 850 Views
  • 2 replies
  • 0 kudos

Fan Advice

Client of mine wants him to build a new PC with RGB fans. He wants the fans to have as many LEDs as possible. I'm looking for something that's Aura compatible but also something that minimizes the cabling. My friend's build has some ThermalTake fans ...

Rampage VI Extreme Encore and 2-Strix 2080 Ti's Problem

Hello Everyone,I wanted to start with saying everyone here is great. The info I have found here has helped me troubleshoot some issues previously. Great stuff! I have a problem with my graphics card in PCIe slot . I have been involved with a lot of R...

crosshair 8 hero error

hi everyoneim trying to test boot my crosshair 8 hero x570 with an amd athelon 200ge while I wait for the rest of my parts and im getting q code 02 and the vga led and boot led are lit up. do I have a mobo problem or could it be the 200ge

PLED pin issue

Hello i have just bought a new rog x570-f motherboard , the PLED has 2 pins on the motherboard but my chassis connector is 3 pin socket , if i fit it , then the power button only has one pin , the system does boot like this, but every now and then it...

Hordin by Level 7
  • 1044 Views
  • 1 replies
  • 0 kudos

Sound buzzing, robotic, skipping issue

Hi,I have an issue I can't find a fix. Occasionally the sound start to skip, make strange noise. The last time it happened I restarted my pc and when it was rebooted I had no sound at all. Force reboot with power button after, sound was back and work...

84810
ReASonZ by Level 7
  • 902 Views
  • 1 replies
  • 0 kudos

Case HDD usage LED

I have a C7H with a ryzen 2700X, m.2 2280 SATAIII 512gb SSD and a fractal-design r6 USB C case. The hdd use indicator light is constantly on. But if i would use a standard 2.5 SSD, the light would not be constantly on. Is this normal? Or does th...