cancel
Showing results for 
Search instead for 
Did you mean: 

Asus z690 hero bios issues with my gpu

Undertoker
Level 9
Hi guys I have a 12 900 K in an Asus z690 hero board

I have an issue
When I update the bios to anything past 811 it kills the performance of my gpu

I’m currently running bios 811
My gpu is an Asus Strix 3090 oc

I’ve tried every bios after 811, but all of them halve my fps and gpu performance
I’ve tried all of the newer bios and every one of them literally halves the gpu performance both in synthetic benchmarks like 3D mark and also in games , it ruins my fps and the gpu is showing me about 8800 in the 3D benchmark for the gpu in 1302, 1304 and 1404 bios*
But if I switch. Back to 811 or 803 it’s totally fine and runs as it should

This is a real pain in the ass for me
Is anyone else having this issue ? Does anyone have any suggestions - it is definitely not the gpu that is the issue as I’ve tested it in numerous other boards and it is perfect - but in this z690 hero board if I update the bios from 811 it halves the performance of my gpu

Help*
I9 14900K >ASUS ROG Strix RTX 4090 OC Edition
ASUS ROG MAXIMUS Z690 EXTREME EATX Motherboard
ASUS ROG PG35VQ @ 200mhz in 3440x1440
Trident Z RGB 64GB DDR5 @ 6400mhz
Samsung 980 EVO Pro M.2 x 5 off
NZXT Z63 Kraken AIO CPU Cooler
NZXT H700i + Hue 2 (Pubg Edition) - Heavily modified
ASUS ROG THOR 1200w PSU
Corsair M65 RGB Mouse
Corsair K95 RGB Keyboard
790 Views
1 REPLY 1

Undertoker
Level 9
Undertoker wrote:
Hi guys I have a 12 900 K in an Asus z690 hero board

I have an issue
When I update the bios to anything past 811 it kills the performance of my gpu

I’m currently running bios 811
My gpu is an Asus Strix 3090 oc

I’ve tried every bios after 811, but all of them halve my fps and gpu performance
I’ve tried all of the newer bios and every one of them literally halves the gpu performance both in synthetic benchmarks like 3D mark and also in games , it ruins my fps and the gpu is showing me about 8800 in the 3D benchmark for the gpu in 1302, 1304 and 1404 bios*
But if I switch. Back to 811 or 803 it’s totally fine and runs as it should

This is a real pain in the ass for me
Is anyone else having this issue ? Does anyone have any suggestions - it is definitely not the gpu that is the issue as I’ve tested it in numerous other boards and it is perfect - but in this z690 hero board if I update the bios from 811 it halves the performance of my gpu

Help*

and sadly this thread shows exactly where the asu’s. immunity is now
it’s non existent Â*Â*
I9 14900K >ASUS ROG Strix RTX 4090 OC Edition
ASUS ROG MAXIMUS Z690 EXTREME EATX Motherboard
ASUS ROG PG35VQ @ 200mhz in 3440x1440
Trident Z RGB 64GB DDR5 @ 6400mhz
Samsung 980 EVO Pro M.2 x 5 off
NZXT Z63 Kraken AIO CPU Cooler
NZXT H700i + Hue 2 (Pubg Edition) - Heavily modified
ASUS ROG THOR 1200w PSU
Corsair M65 RGB Mouse
Corsair K95 RGB Keyboard