Showing results for 
Search instead for 
Did you mean: 

ASUS RoG Thor 1200W psu OLED says "2w" and fan never spins

Level 7
Installed ASUS RoG Thor Platinum 1200W w/ RGB & OLED display.

First installed it on an MSI MPG X570 Gaming Plus w/3600X to test it out when it arrived.
Powered it on and the stripe, badge, and logo lit up red and the OLED kit up white with a transitional display that said ASUS, Thor, 1200W, the logo, and then just "2W"... and that's pretty much where it stays. It switches to 1W sometimes but that's it.

I installed the Aura software hoping that it just needed to communicate with the software to get more accurate data or something along those lines but I don't see the RGB connector for the PSU anywhere so couldn't try that. A couple friends who are more familiar with ASUS products and components in general assured me that it doesn't need the RGB cable to display the correct data.

Then I noticed that the fan hadn't kicked on. Not even once after running for 2 days.
I thought maybe I needed to push the OdB button to get it to turn on (I'm not sure if pushing it in is supposed to turn 0dB mode on or turn the fan on).

So I pushed the button... and it shutdown immediately. Like a power failure.
I had to unplug and switch it off for a few seconds before I could get it to turn back on so, yup, power failure.

I switched it to our new ASUS ProArt X570 Creator w/ 5950X build today (same M2 SSD c:drive) hoping it would like the ASUS mobo better.
Nope, same issue. Only difference is that now it occasionally goes up to 3W.

I tried it with the following components so that I could be absolutely sure it was using more than 2W

• MSi MPG X570 Gaming Plus
• AMD Ryzen 9 5950X
• 1 stick of 32GB Kingston FURY RenegadeRGB 3600MT/s CL18
• EVGA GT 710 using 2/3 of its displays
• Dual Intel NIC PCIe card with internet and IpMIDI network connected to 1 of the ports
• RedNet PCIeR Dante AVoIP interface card
• Native mobo NIC connected to Dante audio network
• 4 port USB3 PCIe cars
• HypeX RGB keyboard
• Rocatt RGB mouse
• MSi MPG Coreliquid K360 cooler
• Thermaltake View 37 ARGB case with its 2 massive front RGB fans and 140mm rear RGB fan
• Galaxy S21 Ultra charging from a USBC port
• 2 software licenses dangles
• 1TB M2 SSD
• 2 USB3 SSDs

I'm not sure how much power that requires but I'm pretty sure it's more than 2 watts. It powered everything fine but still the OLED never displayed over 2W and the fan never kicked on.
I tried with both the 0dB button pushed in as well as out.

It seems to me that whatever it uses to get its information for the OLED is likely where it gets the temperature info that it uses to know when to run the fan also and clearly it's not getting the right information.

Does anyone know more about this? Is there something I can do or do I have to go through the trouble of shelling out the money for another PSU while I wait for a refund?
I really like the idea of this PSU if it actually did what it was supposed to.