Showing results for 
Search instead for 
Did you mean: 

ASUS ROG STRIX Z490-I + LSI Megaraid 9271-8i

Level 7
I have a LSI MegaRAID 9271-8i card which I have set up a virtual drive in RAID6 used as my secondary drive as a file server at home.
Unfortunately my old rig running Windows Server 2012 Essentials gave up on me. I tried updating to Windows 10 but my old motherboard didn't support Win10 so I ended up building myself a completely new computer.

Before that, I tried moving the RAID-card (PCI-e 8x) to my other computer running a ASUS Z87I-Pro board just to see if it would function with this and Windows 10 Pro. And it did. Everything booted like it should and my virtual drive was immediately picked up and usable in Windows.

So I figured this would be no problem. For my new computer I used the ASUS ROG STRIX Z490-I card. First I got the computer running and Windows 10 Pro installed using the onboard m.2 NVME drive. And after everything was running I put the RAID-card in. I had to enable CSM and legacy but after that I could see the MegaRAID BIOS post like it should, the firmware initialized and all the drives are listed correctly including the virtual drive already set up. I can even enter the webbios without a problem. After that the UEFI BIOS posts and Windows starts to load.
However, before the login screen comes up I receive a BSOD with stop code: DRIVER IRQL NOT LESS OR EQUAL. What failed: storport.sys.
This happens even if I try to boot to safe mode or from USB bootable drive as well.

Since the MegaRAID posts correctly this seems like a pure software/settings/driver issue for either the UEFI BIOS or Windows driver. I have tried playing around with different settings but nothing seems to make it work. Getting really desperate so would truly appreciate som help!

What I tried:

- Updating both MegaRAID card and motherboard with latest firmware / BIOS
- Tried preinstalling the MegaRAID driver for Windows10 (however don't know if this works when the card is not present in the rig, I can't boot into any mode to try installing it once the card is in).
- disable fast boot
- enable CSM (Boot device control: UEFI and legacy, Boot from network/storage/PCI-E: legacy only)
- Secure boot, OS type: both Other OS and Windows UEFI
- Secure boot, key management: removed keys
- Interrupt 19 capture: enabled
- SR-IOV both enabled and disabled

Please help! Or will this card just not function with my RAID-card?

Also tried different settings in regards to power management for PCI-e and speeds (not sure if I have tried every combination)

Level 7
After tons of troubleshooting and additional trial and error I was finally able to pin-point the problem. It seems to be the Windows 10 Pro version 2004.

Like I wrote in my orginal post, the RAID card worked in my other computer running Win10Pro. When someone asked me in another forum which version Windows I was running I came to the idea of testing the same version of Windows in the new computer.

So I downloaded an older ISO for Windows10 with version 1903 (build 18362.300) which was the closest thing I could find. I then formated and reinstalled using this build. I put in the RAID card after everything was running and VOILA it works like a charm. Windows starts like it should, the virtual drive is found.

I have tried running Windows update. For now only version 1909 has been installed (build 18363.900) and the RAID-card still works and Windows starts. However, the 2004 update isn't found by Windows Update (yet). Would have loved trying to updating to it to see if this would then fail the system again or if it's just the clean install to it that has this problem.

So problem solved! Atleast temporarily, I still wonder what will happen that day when Windows updates to build 2004.
How do I properly forward this issue to Microsoft etc so they can have a look at it?