Showing results for 
Search instead for 
Did you mean: 

ASUS ROG Rampage V Edition 10 and WD Black SN850x

Level 7


I've recently bought WD Black SN850x and tried to install it to M.2 socket. Motherboard does not detect it.

Is there any chance that it can work?

I have Intel 6900K, Rtx 3070 TI OC.

No additional cards.



Hello lem21h

I don't see why it shouldn't work, but when a drive is not detected it can be due to a faulty drive, incompatibility or bios settings.

Have you tried resetting the bios to defaults?

Updating to the latest beta bios could help.

Have you tried reseating the drive?

Check in the bios, Advanced tab, Onboard devices configuration that M.2_1 is set to the correct configuration.

In the bios on the boot tab, does it show in the boot list?



Well it does not work. Not visible in the list of devices. I've tested that disk also on a laptop that has support for NVME Gen 4 and works perfectly.

I have reset to Bios defaults. 

As I don't have extreme version and I don't have any settings for M2 in Advanced / Onboard Devices Configuration.

I have only 1 M.2 socket

And yes I have the newest available version of Bios for that motherboard