Showing results for 
Search instead for 
Did you mean: 

ASUS ROG GL502VM (7th generation) keyboard not working

Level 7
ASUS ROG GL502VM (7th generation) or GL502VMK.
Keyboard is unresponsive , backlight , power button and touchpad works fine.

I bought a second hand GL502VM (7th gen) few days ago, at the very first start it asked me if i wanted to delete the TPM Trusted Platform Module pressing F12, so i pressed F12.

Then few minutes later while setting up windows 10 the keyboard stopped working, after finishing the set up with the help of the on screen keyboard, i tried to reinstall the drivers, atk package etc.. nothing

The next day keyboard worked by itself at the start, it was all good for the whole day, i did a fresh windows 10 install, updated all the drivers found on asus website, played video games, everything worked perfect

Today, here we go again, keyboard doesn't work, none of the button work, no F keys, no ESC, no Window key nothing, except the power button.
I had set the backlight ON the previous day, so the backlight works, the power button works fine.

So far, i checked :

- ribbon cable for loose connection
- updated the bios to the latest 305
- did a hard reboot
- updated every driver
- tried to change keyboard driver from PC/AT Enhanced PS/2 Keyboard (101/102-Key) to HID Keyboard device
- deleted the keyboard from device manager so windows can reinstall automatically a good driver at restart

Nothing worked, it is very frustrating.
Other than that, i like the laptop, i wish it worked.

I found few other post with people having the same issue without being able to fix it.

Can somebody have any idea?

Thank you

I had the same issue with my GL702VS where the keyboard stopped working in Windows/BIOS apart from the power button.

I found the fix deep in another topic for a different laptop where someone mentioned it fixed their GL502V which I believe is the same physical keyboard as my GL702VS. The fix is for many different GL series laptops.

My keyboard is now working 100%.

Level 7

If you guys have found a fix kindly share it.

My asus gl502vmk core i7 7th has a keyboard Problem. Only the power button work.