Showing results for 
Search instead for 
Did you mean: 

Asus Mobo, Asus NIC, power trouble

Level 9

I have recently bought a new Asus mobo due to my former CPU failure.
The new board is a B450f Strix.

I am using it with a Ryzen 3600. I also have an Asus NIC, the XG C100C (I have a 10 Gb ISP)

This card used to run flawlessly on my former mobo (an Asus Maximus VIII Hero).
But with the new card it behaves rather strangely. As soon as the PC goes into sleep mode, the card is disabled. All my connections are lost, the card is disabled, I cannot continue my downloads, etc. When I wake the PC (with my keyboard) I can clearly see that the card is disabled, and then it is being enabled again after a couple of seconds, from 5 to 20 I would say. Then things run normally again.
This behaviour didn't occur with my former setup: the card was running 100% of the time. I'd like it to run this way on the new motherboard.

I have tried some workarounds:
- In Windows, tweaking the Ryzen power plan (balanced)
- In BIOS, I disabled ErP and checked that the feature (resume from PCIe, was enabled)

But no go, my card is always disabled. Of course I can simply disable the sleep mode completely, but it is not optimal.
I have contacted Asus support but they were of no help.
Do you think it is because of the chipset B450? I'm thinking so, because my former build (intel Z170) worked poerfectly. And this is my second B450 mobo, the first one being an MSI Tomahawk max which gave me the exact same results...
Or maybe I have simply forgotten a well hidden BIOS setting?

I'm starting to be desperate! If you think of any solution that would be GREATLY appreciated

Level 9
any tips, anyone?