Showing results for 
Search instead for 
Did you mean: 

Asus H310M-E motherboard and Linux

Level 7
I've been using Linux for 22 years, and wanted to put it on my new computer with 8 gen i7, nvidia Geforce GT 710 16mb 2666 DDR4 ram Asus H310M-E R2.0 motherboard. While described as a Gaming machine it has no fans apart from the CPU and normally is very quiet while able to handle some of the large graphics and video files I process.

After disabling quick boot in the bios (version 1007), with the latest Linux Mint live DVD I got PCIe Bus Error: severity=Corrected, type=Physical Layer ... scrolling down the screen at high speed. It eventually booted but with errors on the display such as you might see on your TV with a bad signal. Small errors.

I wasn't keen on this and tried Manjaro Linux which booted up with no errors but it would freeze the mouse and become unresponsive after a few minutes. Meantime the CPU fan was in overdrive. I installed Manjaro with EFI partition for the UEFI bias and it would run for ten or fifteen minutes again with the CPU going into overdrive before freezing and if I checked the BIOS it was about 45 degrees instead of the usual 29 it runs at with very little CPU fan in windows, fan set to quiet.

I Googled the issue and found this link on overclocking where the system seemed to do something the same or similar.!-System-hangs-freezes-when-overclocked
However I didn't overclock, the RAM I have is 2666 max speed for the motherboard, and I couldn't find XMP in the BIOS Ai settings so this could be a red herring.

Last month I bought this machine, but originally got the 320 motherboard with AMD however that wouldn't get past setting Windows up for 2 or 3 minutes without the same phenomenon of lots of fan noise and unresponsive mouse and screen. The shop was going to replace it but I opted for the intel machine and paid a little extra.

Today I found a link to Linux Status Report for ASUS Which showed variants of my motherboard working with Fedora and Ubuntu , it had the H310M-D R2.0 not the H310M-E R2.0but I thought it was close enough. I had tried Ubuntu 20.04 on the desktop and it didn't work whereas it had worked on my ACER Nitro 5 laptop.

So I tried Fedora workstation on USB and it booted up without errors and worked for about 15 minutes or so and I was able to shut it down properly instead of having a mouse freeze. The only thing was it had the CPU fan very noisy the whole time as with Manjaro and it was about 45 when I got back into the BIOS, not that this is hot but I wasn't doing much that required CPU. Also when shutting down it did have the PCIe Bus error scrolling very fast for a few seconds, as best as I could read it.

I'm generally very happy with this machine but I would like to have Linux on it as well as Windows. However I don't like having the system freeze up while using Linux and I think there is something wrong with it running hot, hasn't happened on other machines as I recall it. I ran top which gives system information on linux and attached screenshot. I'd like to install Fedora but not so sure about the CPU issue.

Level 7
Hello all, I've now concluded that the problem is a pcie issue, follows is a post to my local Linux Users group. I hope this has a bit more information to help get a resolution.

I had my old desktop die and needed to get work done, so I bought a system off the shelf from a computer shop, 8th gen i7 Asus Prime H310M-E R2.0 16 mg DDR4 Ram 2666, Nvidia 710 graphics. The motherboard has an M2 sata slot which is also pcie x2.

I've been using linux since 1998 but I'm just a reasonably competent self taught user.

The system seems to overheat on Linux. Running top from a screenshot I have CPU 6.0 us, 11.7 sy 0.0 ni 80.8 id, I take it that is 80% idle.

Systemd+ 997 root Pr 20 NI 0 446872 298632 shr 296984 S R %CPU 99.0 Mem 1.8

IrQ/122+ 184 root PR-51 NI 0 Virt 0 Res 0 SHR 0 S R %CPU 36.3

Don't know what most of that is but in comparison to my laptop which is running Ubuntu, Systemd is very very small on that.

When I booted the live Mint DVD I got a lot of scrolling on the screen at high speed, I managed to take a photo of it, it reads: 125.008462 pcieport 0000:00"1c.5: PCIE bus error: severity =Corrected, type=Physical Layer, (Receiver ID) device [8086:a295] error status/mask=00000001/00002000 [ 0] RxErr This is repeated but the 125.00number at the start is increasing while the device8086:a295 is the same.

Mint worked but there were some errors on the display including a little bar under the mouse pointer.

Manjaro worked with everything succeeding in the boot process but it would freeze and become unresponsive after about ten minutes, from the boot dvd and from after I installed it.

Fedora Workstation works but when it shuts down from the usb stick I see these pcie messages just before it closes.

All of them have high fan activity and the CPU is still hot when I get back into the BIOS, around 45 degrees. By contrast Fedora on the Laptop is very quiet with minimal cpu activity no errors and just the usual fans turning on briefly when there is a bit of activity.

I checked online and found a reference where CUPS was causing systemd problems, I ran a command to shut CUPS down but it made no difference. I would think in this case it is the pcie problem doing it.

I'm 80% happy with the system I bought but would like Linux on it. One option might be to take it back and pay for a motherboard replacement, any suggestions welcome on a good linux motherboard for i7 8th gen. Or better still a fix for this issue.

This is the motherboard:

I found a list of Asus motherboards and Linux

That list does show models of the Prime running linux, possibly not my "E" variant due to the list being a few years old.

PRIME H310M-A R2.0 Fedora 28 N/A N/A Ubuntu 18.04
PRIME H310M-C N/A N/A RedHat 7.4 N/A
PRIME H310M-D N/A OpenSUSE 42.3 N/A N/A
PRIME H310M-D R2.0 Fedora 28 N/A N/A Ubuntu 18.04
PRIME H310M-DASH Fedora v27 OpenSUSE 15.0 RedHat 7.5 Ubuntu 18.04
PRIME H310-PLUS R2.0 Fedora 28 N/A N/A Ubuntu 18.04

Regards, David.