Showing results for 
Search instead for 
Did you mean: 

A2 error code, need help

Level 7
Hello, I'm in need of help, I've been looking for a solution to my current situation on getting rid of post code error A2. Unfortunatlely all the info that I've thus found is to no help to me and I would like to present my issue with anyone willing to help out.

A bit of a backstory first. My current build is not new I've had this set up for about half a year enjoying my games and such. I was planning to watercooled my rig for a long time and took time to get all the necessary components. So in the last few months I finally got everything I needed to get going on putting a custom watercooled system. So I began the task, after I finished putting everything together I booted the system and I was greeted with a 55 error code. I looked online to find the answers and drained all the fluid out of my system and went as far as removing the cpu to check for bent pins I couldn't figure it out at all. So I then decided to strip the entire build and start from scratch. As I was doing just that I decided to just turn on the system and the error code 55 was gone, it showed A2. I put a few things back into place to see if I can replicate the 55 error code and found out that my Aquacomputers USB hub was connected incorrectly and causing a short on my system.

So now I'm greeted with only a A2 error code. Mind you this is showing with only a M.2 drive installed. I have an SSD and HDD but they were not connected when I first got the A2 code, this lead me to beleive that I could finally get into the BIOS cause I had pressed the clear cmos button several times be this. But I also didn't have a display connected either so I put everything back together filled my loop again and hooked up everything booted and I still have the A2 error but Im not getting anything to show on my display. Weird thing is my keyboard is working and when I press F1 the code goes to A0 and everything seems fine just still no display. I connected an hdmi from the motherboard to the display and still nothing. I've reseated all of my RAM sticks and used just one on every slot still nothing. I'm really stumped on this one and need of any help.

My current rig:
Asus Maximus XI Extreme
Intel Core i7 9900k
4x Corsair Vengeance RGB Pro 8GB
Asus Strix RTX 2080 Ti
Samsung 960 256GB M.2
Samsung 970 1TB SSD
WD Black 2TB HDD

Again everything was working perfectly before I installed the watercooled components.

Level 10
I had the same problem a while ago but it was happening due to the wrong connection between the graphics card and monitor. At that time I had plugged into a Panasonic TV and for some reason, the graphics card wasn't displaying anything at all. I couldn't find any information about the A2 error code anywhere on the net.

CODE A2, IDE Detect, error code means it's having trouble detecting or reading connected drives. This often occurs during initial boot of a new build if multiple drives are hooked up before an OS is installed.

possible solution

I encountered this A2 error code issue with an Asus Deluxe WiFi board and the sync/charge cable for a Polar Loop wrist band (the cable had been plugged in while pc was shutdown)

Removing it and rebooting worked.

Posting for the sake of posterity.