cancel
Showing results for 
Search instead for 
Did you mean: 

A devilish problem with Maximus XIII Hero and i9-11900K Q code d4 and its reincarnati

cemster
Level 7
Hello,
I rebuilt my workstation from 10 years old P9X79 WS to a couple of months old ROG MAXIMUS XIII HERO coupled with an 'Intel i9-11900K', 'Corsair VENGEANCE® LPX 128GB (4 x 32GB) DDR4 DRAM 3200MHz C16 ' and an 'Asus GTX 1660Ti...

The reason I have a new build is that towards its last days the old build it started to freeze... It was a hardware problem.
The first thing I replaced was my GPU card with ASUS DUAL GTX1660TI O6G EVO. Which is also my GPU card of the new build. And also a quite new purchase.

The problem I am having is 'White light' sometimes followed by "1 long 3 short Beeps"...
And Q code displays "d4" but the post continues after a while and it settles on "A0" And as the hard drive light blinks away, as the "White" light indicates a GPU error remains and no signal is received by the monitor.

This Q code 'd4' has started right away with my very first boot attempt. However, as I rebooted, it did not give any error on my second or on the third try. Which I kept the system on, almost for three days at that time. Then next day on the fourth booth, it stuck on GPU card error again. This is how it continued for six days.
And on that sixth day, after a successful boot, the system and the monitors freeze after a while! You know as my old build did! So, I rebooted again, it freezes again in a few minutes. And after that, I couldn't pass the GPU error; the "d4" and "white light" and the "beeps". Yet the post continues and the Q code finally displays "A0". Meantime, the GPU card shows a "White" light as oppose to a "Red" light and both mobo and GPU card illuminate RGB lights.
When the system was working I had many HDDs and an SSD installed, and a few USB-connected devices plus fans, all working fine.

Now, I just have an SSD and 8 fans. I have an i9-11900K cooled by a Noctua NH-14 with two fans. That's it. I even unplugged anything coming from the case such as USB connections and whatnot.
I power the whole thing with a Corsair AX1200i PSU, and it is the only thing that I haven't replaced from my old system...
It shows the green light and seems working fine also monitored with its "iCue" app when I could boot. When the system was working I checked every component.
Rams were showing 64 GB instead of 128GB. I realize that two of them weren't properly placed so I corrected that and got 128 GB. I checked each Ram individually and they were ready for OC and they were showing proper voltage and everything. Same with the CPU. Each core seemed to be functioning normally. At one point it even OC'ed %10 with auto OC.

Even though I do suspect the PSU, I can't be a hundred percent sure if the PSU is really the problem...
I couldn't figure out which device was the faulty one with my previous system either. I took my system to three different shops for testing and none of them couldn't find anything wrong! Even with all the stress tests and whatnot, they couldn't even manage to duplicate the system freeze... And as soon as I get home, I get the "frozen screens" which they couldn't produce. Once even for a consecutive three days, they fished for the error and got nowhere...

So, as you can see it is weird luck I am having. It feels like this is a curse really...
I replaced the GPU card first and that didn't help. Nevertheless, I realized I replaced the wrong device. But maybe as the previous GPU card (Zotac) was faulty and with my bad luck, the new GPU card that I bought was/is also bad. Then, I end up replacing everything except the PSU.
I just don't want to buy a new PSU and find out that in fact, it was the GPU card that was the problem all along...

So I did two more tests today. First I removed the GPU card. Since I have the integrated CPU graphics. But I get all the same errors. White mobo light and beeps...
Then I managed to borrow a 600 watt Thermaltake PSU. I hooked up with high hopes that it would work and I can finally pinpoint the faulty device after all the drama.
But no such luck! I still am getting the same errors. And now the white light is accompanied by a Yellow light as well, indicating that something wrong with Rams too...
When the Corsair AX1200i was connected, and the white light came up, the yellow light also came up for a very short while, and as the post continues the yellow light went away as the white light remained every time.
However, with this 600 Watt PSU, the yellow light also remains and the post does not continue... So 'd4' is the final Q code there...

This is even more confusing. I am baffled. Is it the new Motherboard that is the problem?
'D4' is explained as either integrated GPU, or if a GPU card is installed the GPU card is not detected or has a problem. So they suggest checking the CPU! But the CPU was working just fine a week ago. As all the Rams were...
All my parts are compatible. I did my research! Matter of fact, both Asus and Corsair gave me their blessings personally. Asus put some 128 GB Corsair rams that higher than 2333 MHz into their compatibility list after my request. The video card is also listed as a compatible device.

My BIOS is the latest version. And I know what d4 means. But as the story goes, my last test did not even involve the Video Card as I've removed it from the motherboard.

Also when it worked, it did work fine... As short as it was...

I also did reset the CMOS a couple of times.

Also, all my parts are compatible. I did my research! Matter of fact, both Asus and Corsair gave me their blessings personally. Asus put some 128 GB Corsair rams that higher than 2333 MHz into their compatibility list after my request. The video card is also listed as a compatible device.


I am running the latest BIOS. I updated the unit before running the system through Asus's USB port. The drivers were installed through the driver disk that came with the unit.

Nothing is automatically updated in my system.

I also should mention that

My wiring is done by an engineer. I have 2.0 ohms ground provided by a fat copper rod
buried under the ground 4 feet deep, connected to my system with a thick copper cable. The audio equipment is on a dedicated circuit.
I have a superb power conditioner. (Which just in case I tried bypassing the UPS as well)
So I do have a clean and balanced power in my studio.

I don't know where to go from here?

And if you read the whole thing I appreciate it, I know it's a lengthy one but so is my curse...
2,574 Views
5 REPLIES 5

cemster
Level 7
So... What I guy gotta do to get a drink around here?

the Q code D4 is now D6...

And what a caring forum this turned out to be... G thanks...

Hey there... I'm a little late and having a slightly similar issue. I'm not sure if you ever figured out what the problem was and whether you were able to fix it or not, I believe it's a compatibility issue and can be fixed through settings in the BIOS.

I upgraded just my mobo/cpu keeping everything else including my GTX 1080. Initial startup and every startup afterwards resulted in one long and three short (1/3) beeps followed by 1/4 beeps with a code of D6. It wasn't detecting my graphics card. I thought maybe my cards took a dump so I swapped it with my daughter's ancient GTX 680 and it fired up just fine. Yeah, it makes zero sense, I know. I was able update the BIOS and drivers. I swapped my 1080 and still got the same problem.

Now, there's some data missing from my organic storage device that would reveal how I ended up in my BIOS, going to Boot, and enabling CSM which made everything work just fine. I'm no genius by any means, but I'm grateful for who/whatever led me to this solution.

I recently decided to mess with the overclocking and followed the instructions in the AI optimization guide in the BIOS and went back to the default UEFI settings to start the OC calibration process. Well, when I did this, my VGA error issue came back. Good thing I got a glimpse of the settings that were being changed before I F10'd out.

Also, I believe a part of reason why your post received no responses until now is due to the issue affecting such a small amount of people, there's not enough information out there about it even the biggest enthusiasts are aware.

Anyway, I hope this helps someone.

i sent 3 motherboards to Asus for repairs, still no luck on a good one.


Mine motherboards after some random time windows freeze , the mouse still moving but can't open or close all apps not responding, can't reboot or shut down pc, only forced shutdown could be performed.

Tried the other 3 types of memories Corsair , tried 1 stick 2, or 4.
Tried 2 ssd drives
Tried 2 power supllies
Tried another i9-11900K processor
Did run memory test for a couple days no problems till freeze
All latest drivers available from asus website. Armoury crate also up to date all drivers

cemen wrote:
the Q code D4 is now D6...

And what a caring forum this turned out to be... G thanks...


Are you OP ? Because different username...
Also, on point, I do not understand what you problem is, really. Because as far as I can tell, your system is working yet you complain about D4 and D6 and white LED errors.

I have a feeling you effed the pins in the CPU socket.