cancel
Showing results for 
Search instead for 
Did you mean: 

1080TI ROG Strix PCIE cables

pidgey
Level 7
CPU-I7-7700k
GPU - ASUS 1080TI ROG Strix OC
PSU - SeaSonic PRIME Titanium 850 W 80+

Can anyone please tell me for certain if these are the correct cables to use? I am concerned because there are 2 pins missing metal connectors on each of the 8 pin cables on the PSU side as you can see here.

https://media.discordapp.net/attachments/485045139878838282/825166275620765706/unknown.png
88140

My 1080ti strix crashes almost immediately after opening certain apps and when I run the heaven benchmark. I've underclocked, overclocked, forced voltage but nothing works. It starts at high fps with good temps and then it freezes, recovers after a few seconds, and repeats. I've swapped it out with my old 970(using same cables) for now and have no issues freezing or crashing on the same applications

So i think the issue is one of these 3 things-
a) Faulty gpu
b) Wrong pcie cables
c) Faulty PSU doesn't get anywhere close to 850w, 1080TI hits its unknown limit but the 970 doesn't

Let me know if anyone has had a similar experience or can give any input that may be helpful. Would be great if I could fix this without buying a new gpu

Thanks for any help
507 Views
2 REPLIES 2

walishah3211
Level 7
try another wire looks like your wires need to be change

pidgey
Level 7
I'd like to but I don't know what the correct wires are supposed to look like. Can anyone please show me how many metal connectors are supposed to be on the psu end?