cancel
Showing results for 
Search instead for 
Did you mean: 

Stuck on BIO Screen

rentaldolphin50
Level 7

So i was just playing games on my Rog Ally and i turned it of for about 2-3 minutes to charge, when i got back to it, it would only boot up the BIO Utility IDK why so i thought to exit but it brought me back to the bio. so then i removed the SSD card and put it back thinking it was lose and that didn't fix it ( I never changed the SSD card its still the same when i got it). I try window recovery but i would always get the message that it fail. IDK if its a software issue or if i need a new SSD card even though when i check is said its fine. I tried almost everything i thought of even changing the setting of the BIO.

136 Views
1 REPLY 1

Anbby_ROG
Customer Service Agent

Hi @rentaldolphin50 ,


I'd like to confirm if you're currently experiencing the issue of being unable to enter the system and only able to access the BIOS setup screen.
If so, could you please check if there are any issues with the volume keys being stuck?
Have you tried using Cloud Recovery to see if you can restore and access the system? Thank you.