cancel
Showing results for 
Search instead for 
Did you mean: 

ROG Ally won't update, buttons don't work, and RGB lights don't work

daniellee789
Level 7

Hello,

I have been trying to fix this ****** thing for days now. I bought this as an open-box (excellent) from Best Buy, and ever since I set it up, it has not been working correctly. None of the buttons work. I can't even play most games because none of the controls work. I have tried everything from a factory reset, cloud reset, uninstall/install Armoury Crate SE and nothing has worked. I can't update the MCU firmware from Armoury Crate or MyASUS, and I am out of ideas at this point. This was meant to be a graduation gift for my partner, so it is very frustrating that she has not been able to use it yet because it just won't work.

Any help would be appreciated!

535 Views
1 REPLY 1

Anbby_ROG
Customer Service Agent

Hi @daniellee789 ,

I would like to confirm with you whether you have tried uninstall tool, removing Armoury Crate SE, and then reinstalling it

Based on your description, it's possible that your ALLY may need further hardware diagnostics at a service center. If you recently purchased the product, I recommend seeking additional assistance from the dealer where you made the purchase. The information provided above is for your reference. Thank you.

Due to the ongoing regional holidays, my responses may be slightly delayed.
Thank you in advance for your patience.‌‌‌‌