cancel
Showing results for 
Search instead for 
Did you mean: 

Rog Ally won’t boot stuck at Republic of Gamers screen

Jamey8211
Level 7

I didn’t touch my Ally for a few days but left it plugged in on the stand. I noticed the screens backlight looked like it was on so I reached and picked it up. It was hot really hot. So I pressed the power button to turn on and it chimes and Republic Of Gamers appears on screen. Nothing happens after that no matter how long it stays on? I’ve tried all the recommended button press combinations and nothing changes. 

685 Views
5 REPLIES 5

Anbby_ROG
Customer Service Agent

Hi @Jamey8211 ,
Please try removing the power source and all external devices, then press and hold the power button for 30 seconds. Afterward, reconnect the power source and test to see if the system can start up normally. Thank you.

I don’t have any external devices and have tried this with and without the power connected with no change? 

Anbby_ROG
Customer Service Agent

Hi @Jamey8211 ,

Can you currently access the BIOS interface? (Using the volume down button and power button)
If you are unable to access the BIOS interface, we recommend that you take your ALLY to a local service center for further diagnostics. We apologize for any inconvenience this may cause.

No I’m unable to get past the initial Rog screen. No combination of buts work. And yes thanks I have an appointment with best buy tomorrow at noon. It’s just almost 100 miles away so I have a long day ahead. 

So I can access the bios screen but it doesn't show a storage device.