cancel
Showing results for 
Search instead for 
Did you mean: 

ROG ALLY stuck on Republic Of Gamers. Like many others.

Jonazz
Level 7

So hi.

So i this Z1 extreme not long time ago. Got it from another guy who did not use it at all.

So ok was very happy for the machine... software is a bit.. needs work but not the problem.

I used last night no problems got new games, played and so on went to bed so turned it off. BUT! 

When i woke up it was on and have the Republic Of Gamers stock.? HOW THE FU.... DID THAT HAPPEND?

Now i cant get into bios, and stock on the screen. Have tried everything what its writing here and videos and so on. 

It was not hot, it is not hot.. and so on. Did Asus just design these to die right before or after warranty?

How do Asus not fixed this yet or made some call out if it keeps happening?

484 Views
12 REPLIES 12

Perrin79
Level 7

Had the same issues.    Hold down the volume down button after powering on.   The bios will come after you put in your user or administrator password.  When in Bios hit the save and exit  button.    The system will go off then comeback on a few times.  You may have to put in your password a couple of times when the system powers off and then back on.   You will get to the home screen after about 2 power off and on cycles

Jonazz
Level 7

Sorry as i said.

Being trying all the things. 

This method like a million times. And don´t work.

I dont get into bios but hold down then power.

Anbby_ROG
Customer Service Agent

HI @Jonazz ,

I would like to confirm with you, is the device able to boot into the system normally but unable to access the BIOS settings screen, or is it unable to boot into the system altogether?
Please try removing all external devices and power sources while the device is powered off, then press and hold the power button for 40 seconds to perform an EC reset. Afterward, reconnect the power source and boot up the device to see if there is any improvement. Thank you.

Don't anyone read what I'm writing?

I been trying all these things and still stock. 

 

Tested everything again, and again still stock.

cl-Albert
US Customer Loyalty Agent

Hi,

Thanks for the video and know you may have been trying to demonstrate the EC reset was performed correctly, but also wanted to confirm you gave the system enough time to boot since it can sometimes take longer to boot after a bios or other update.

Don't expect it would normally take longer than 5 minutes, but you may want to give it 5 or 10 minutes to boot just to be safe and make sure the system boots normally the next time since it shouldn't take that long to boot every time.

If you haven't tried to load the default bios settings and don't mind, you may want to try that later too once you can get into the bios just to make sure everything is okay there if there was a bios update recently.

If you haven't tried to load the default bios? The volume down plus Power on? 

Again been trying everything. Been writing that a few times now.

Now been waiting for 30 mins on boot logo nothing happend.