cancel
Showing results for 
Search instead for 
Did you mean: 

Rog Ally stuck at logo. How can I manually reset the BIOS settings?

Dhhfhfhf
Level 7

After the BIOS modifications, my Asus ROG Ally is stuck on the logo or on a black screen; full disassembly and attempting to discharge the BIOS chip didn't help. I couldn't find the BIOS chip battery on the board. How can I manually reset the BIOS settings?

703 Views
7 REPLIES 7

Anbby_ROG
Customer Service Agent

Hi @Dhhfhfhf ,
I'd like to confirm which settings in the BIOS you modified.
To ensure your warranty rights, we do not recommend self-disassembly of internal components to avoid accidental damage or other abnormalities during the disassembly process. We suggest that you take the product to a local service center for further assistance. The above information is provided for your reference. Thank you.

Standard answer, thank you.. 

cl-Albert
US Customer Loyalty Agent

Don't know that it can make any difference, but noticed after possibly some updates, the system can take longer to boot and stay at the ASUS logo for a while, so if you haven't given the system a little more time to boot, you may want to try that and just make sure the system boots normally afterwards although you may also want to consider loading the default bios settings if you don't have any concerns about trying that.

Although the FAQ below doesn't reset the bios settings, you may want to try to hold the power button for 40 seconds to do a 'hard reset' when the system isn't powering on to see if it can make any difference, but is really for a different issue and may not help.

[Notebook/AIO/Gaming Handheld] How to Reset Embedded Controller (EC Reset), Real-Time Clock (RTC), a...

It didn't help, the indicator doesn't start rapidly flashing ; in fact, it doesn't do anything at all. I made changes to the BIOS using a third-party Utf (Smokeless_UMAF) BIOS from a USB stick and changed the settings of the standard BIOS. I've already ordered a programmer (ch341a) to manually reflash the chip, but it would be convenient to reset the BIOS or reinstall it without these actions. Now, it's still the same: the logo appears, and the processor heats up a lot. I've tried everything and read a lot when pressing the button.

cl-Albert
US Customer Loyalty Agent

Okay, unfortunately, not aware of other options to help with this.

I'm one of those enthusiast guys who buy a device and, regardless of losing the warranty, immediately disassemble it. People like us contribute to the development of products (we're like free testers). It would be cool to make such processes simpler, for example, the ability to load the BIOS from scratch just by inserting a USB stick into the device and pressing a certain button. That is, easy solutions to not-so-easy emergency situations.

The main problem is that the BIOS chip 74M25JWEIQ Winbond used in the Asus ROG Ally has NAND type memory, which doesn't get erased when there's no power. That means if there was another chip that contained the very first, oldest BIOS for this console, which could then be installed onto the main chip, this could also solve the problem.

Or something similar to these options; I could send the console to service, but it's tedious and requires waiting.

By the way, if I additionally press the volume keys or connect the dock station, sometimes instead of the logo, I get just a black screen, and it stays for another 1-2 reboots (but this happens rarely, if you press everything in succession).