cancel
Showing results for 
Search instead for 
Did you mean: 

ROG Ally SD Card Reader Not In Devices

Bloombud
Level 8

The SD Card Reader Hardware isn't even showing up in my devices list when trying to look into updating/reinstalling drivers.  I just bought a microsd card today to try and add storage for more games, and come to see that on my Ally it seems the hardware isn't even connected/showing up at all.  Help.

17,083 Views
96 REPLIES 96

saffref
Level 9

Same here. The SD card reader worked fine for about 10 days, then progressively failed (for a while, it read some cards, not others, which is especially weird). Now it is completely gone (not showing anywhere: device manager, disk manager, file explorer...) Factory reset through ASUS Cloud didn't resolve the issue. Several days discussing it with customer service led them to grudgingly accept it is probably a hardware failure and ask me to send it back. Shortest repair time: three weeks! (Not to mention the hassle.)

Hi @saffref , did you follow up with shipping in your device for repair/replacement under the warranty?  I think I will need to do the same thing with my own ROG Ally device to have them replace the SD card reader. If you've already taken the steps needed to send it to Asus for the repair, would you mind following up on this thread with updates on what the process is like for you?  It would be greatly appreciated and likely helpful to any other unfortunate customers whose Asus ROG Ally was sent with defective hardware of the SD Card Reader itself. 

hankmaclovin
Level 7

I don't know how Asus did it but I did the test with two micro SD cards of 512, in two weeks both were made unusable after 10 days of games. We will have to remedy this quickly.

MasterC
Community Admin
Community Admin

We want to thank the community for the passionate response we've received for the ROG Ally. Your support has been both immense and invaluable, so we've been hard at work to improve a number of things. After confirmation from internal testing, under certain thermal stress conditions the SD card reader may malfunction.

To alleviate the issue, we will be releasing an update that further fine-tunes the default and minimum fan speeds on the device to improve reliability while keeping fan noise in check, as we know this is a concern for many of you.

If you are currently experiencing issues with your micro-SD card reader, please contact customer service for your region to RMA your unit, which we will inspect for any issues and repairs. For ROG Forum members residing in the US, please private message Silent _Scone, MasterC, or CL_RL_ROG.

_____________________________________________________________
FPS, Racing, and VR Gamer / Tech Enthusiast / ROG Admin

I believe the thermal stress failure is due to the usage of higher speed sd cards reads/writes, in conjunction with a faulty sd drive driver.  I have a Macbook Pro that had sd drive issues that was fixed by an updated driver.  No increased fan curve was needed for the Macbook, and I believe the Macbook has a similar sd drive to the Ally.  

I hope you are right. After my first Sandisk Extrem 512 card faild on the Ally (still working perfectly on my other PCs), I bought a new Samsung EVO 512 U3 V30 A2. I've installed some games (max 10GB in size) from steam onto it and it runs no problem at all so far. Than I insert the new SD card to one of my laptops, the computer doesn't read the card correctly. ASUS really need to do something about this, this is getting crazy!  The bright side I guess is that it maybe not a hardware issue, since my Ally has no peoblem with the new Samsung card and other old SD cards I have around. When I first got this SD card issue, I was doing nothing with the Ally but downloading steam games into the internal SSD after the 322 BIOS update!

We could assume or guess what the cause might be, but at the end of the day, if you believe something is wrong then it's best to send it in for an inspection (I'm sure you have already seen the same statement in multiple threads). Unfortunately, nobody else here can provide a definitive answer for your question because we cannot see or test your unit. 

_____________________________________________________________
FPS, Racing, and VR Gamer / Tech Enthusiast / ROG Admin

Updates. The new Samsung EVO 512 card is now works perfectly fine with the Ally and other devices. But the original Sandisk 512 card is still not working on the Ally (it can be opened in windows but can't write anything to it) but works on all other devices flawlssly. So I went to BB and got a replacment. The new Ally immediately read the "dead" Sandisk 512 card upon first startup! The card is now back to normal and behaves like nothing happened whatsoever. I switched to the new Samsung card, and it works fine, too. I tested copy and paste/delete large files and folders between the SD cards and my internal SSD as well as an external drive, then I downloaded 3 steam games (dark souls remastered, the transformers, cuphead) onto the SD card, played them for about an hour, then I played some emultion games after that, no problem at all. I also updated my new Ally to BIOS 322 with all latest software updates. The device manager displays my SD card reader as a "Genesys PCIE card reader device..." with a driver dated on 4/28/2023. From my personal experiences with this SD card reader issue, I really can't think it is a heat issue. Because I have never played any game in 25w or 30w mode at all since day one. I only used 15w and 10w. My first Ally was never too hot to touch as someone else stated. One thing comes to mind is right before my first Ally's SD card reader fails on that Sandisk card, I was downloading many large games from steam continuously for about 4 hours while plugged in. I don't know if that was the cause of the issue on my device, but that was the only occasion I can remember that has the potential to generate much heat into the device.  

Ok so I am coming in to give more details on what's going on here because I don't think it's a thermal issue. I've gone through 3 micro SD cards (512GB, and two 1TB cards) and two Allys. I can tell you now that the first ally I had the issue with was perfectly fine for weeks before I did an update about a week or so ago. It made my 1TB card inactive. No games would play or even show. No overheating was involved. So I did a amaster reset on the system and used another 1TB micro SD, this time, I didn't do the system updates. Everything went perfectly for a whole day until I woke up to play a game that was stored on the SD card, and it requested an update in order for me to move forward.  So I did the update and next thing you know, I can't play games off of the card again.  Not only that, the card will not show up in any of my devices I put it into, which means the card is now defective. No overheating issues whatsoever. So this time I decide to take the system back and exchange for a whole new ally. I get home, I don't do any updates and I'm playing games without any issues. I slowly but surely do specific updates until I get to one update in particular with the Armory crate and once it downloaded, my games stopped working again on my newly used 512GB SD card. So this time, instead of master resetting the ally, I decided to Uninstall Armory crate and to my surprise, my games worked playing off of my SD card. Now because the Armory crate is gone, there are certain things I don't have access to anymore. Like the controller settings, light settings, etc. But some of my games don't play right because of those missing settings within Armory crate. The final infliction is, I eventually installed the Armory crate and after a Bios update within the Armory crate was completed, my 512GB card was corrupted once more. No thermal issues at all. So out of all of my testing, there seems to be issues within a bios update within Armory crate. Now, I have master reset my system again (with Armory crate installed) except now, I just run a few games off of my internal memory and haven't installed any SD cards until the true issue is found and fixed from Asus.