Showing results for 
Search instead for 
Did you mean: 

ROG Ally SD card not reading!

Level 7

Card stopped reading in Ally though works on my other PC. Though put a different card in the Ally and it works. What's going on? Also seems to be many people with this issue now.


Level 7

Same problem.  It read my 512gb card for a couple weeks.  All the sudden, it stopped working.  I put in my PC and it works fine.  I then took an older sandisk 200gb out of my laptop and put it in the Asus Rog.  it worked fine.  However, the 512 does not.  I thought it was the card so I returned it and got a Sandisk 1TB card.  It also does not work.  It's a brand new card. Tested on my lapetop and it also works.  I tried both NTFS and exFat.

I’ve the same issue. It did work just fine. Now it doesn’t at all. When I plug the car back in I get a windows bleep to suggest it knows it’s there but nothing shows up.  Works fine in my other PC too. 

Hardware issue with the ROG Ally?

Same issue here. It works on PC. It's a SanDisk extreme 1TB

Level 8

Mine did the same

sent it back to asus waiting for it to be repaired but looking at email I got it doesn't go back to them they sent my device to a repair shop in Scotland 

I got a email back from them to say they waiting for parts from asus 

At the end of the day if these have known faults they should replace the device with a new one instead of waiting for new parts to be delivered 


Mine is the same. Sent to some repair company in Nottingham. I wonder if they are doing something different other than like for like swap else this will just happen again

Level 8

Thanks for the answers. I'll contact Amazon and send it back to them for a replace or refund. 


Level 8

Just bought the second one after returning the first, after 3(!) weeks of light use the same issue, sd card not recognized. This is absolutely ridiculous that a device could have passed QA with such flaws. Since the RMA seems to be a mess as well here (still no responses / a global recall from ASUS and the German team only responded with a generic mail) This will definitely be my last device from such a company.

Level 8

I’ve just had this problem last week,

failed to read SD card after 2 months plus, sd can be read on mother devices.

I’ve sent my device for repair. It’s not needs whole new motherboard and various parts internally and will be 3-4 weeks to be repaired.

apparently it’s excess heat.

wish they would just send new one, as I need it back for starfield.

Just had confirmation that I should get mine back within a week. Mainboard replacement too. 

Fingers crossed it works, they fixed mine then failed testing. There Waiting for advice from ASUS now apparently.


I wanted mine back in time for starfield.