Showing results for 
Search instead for 
Did you mean: 

ROG Ally SD card not reading!

Level 7

Card stopped reading in Ally though works on my other PC. Though put a different card in the Ally and it works. What's going on? Also seems to be many people with this issue now.


Customer Service Agent

Hi @MrKong81 、  @Bobbo_uk ,

I apologize for the inconvenience caused.
May I confirm the brand and model specifications of the SD card you are using?
Additionally, I would like to know if the SD card has been unable to be read from the beginning or if it stopped working after some time of usage.
If possible, please send me a private message with your product serial number and the current BIOS version you are using. I will contact the relevant department to investigate this issue. Thank you.

Sorry edited as I stuffed up

We want to thank the community for the passionate response we've received for the ROG Ally. Your support has been both immense and invaluable, so we've been hard at work to improve a number of things. After confirmation from internal testing, under certain thermal stress conditions the SD card reader may malfunction.

To alleviate the issue, we will be releasing an update that further fine-tunes the default and minimum fan speeds on the device to improve reliability while keeping fan noise in check, as we know this is a concern for many of you.

If you are currently experiencing issues with your micro-SD card reader, please contact customer service for your region to RMA your unit, which we will inspect for any issues and repairs. For ROG Forum members residing in the US, please private message Silent _Scone, MasterC, or CL_RL_ROG.

FPS, Racing, and VR Gamer / Tech Enthusiast / ROG Admin

I ran into exactly the same as the others on my ally (used it for about 10 hours so).

What I noticed after some time the read speed of the SD-Card was exactly limited at 25 megabytes per second and after some time it didn't respond at all. I then removed and re-insert it and now it doesn't get detected at all - and I'm having the same issue that smaller SD cards (64 gigs) are still recognized which seems to be related to the reader. May this helps with investigating the issue.

Can anyone tell me how long RMA process will take? Because I don't want to wait weeks for newly bought device.

Mine never showed up like so many other people , how does the company knowing put out a product that is flawed ,its called fraud . I used San disk drive extreme , didn't see anywhere on disk partition/disk manager etc. I used gigastone sd from my steam and i see it on disk partition however i cant access . Just tried to download a game asked me to manage storage and i cant see were it is . Tell me how i access, 

Hi! That's exactly what happened to me after a month or so using the rog ally.

There is nothing you can do to fix it except use the warranty or open a case in Asus and send ir back to them to replace the motherboard. Sorry but there is no other solution

Level 8

I’m having the same issue. I thought my SD card reader stopped working but it seems like it just stopped reading the card I initially installed in my Ally. The SD card is still readable on my desktop and laptop, only the Ally is having issues reading it. 

I purchased a 512GB SANDISK Extreme Pro with my Ally and it’s been working fine for the past month of playing. Granted, I’ve been playing mostly light indie games or older less demanding titles. 

This last week I started playing Diablo IV, I installed it on the SSD for better load times than the SD card, and Diablo IV is a bit more demanding than what I’ve been playing. Weather coincidence or due to Diablo making my Ally heat up more than it previously had been, the SD card stopped being detected the same week that I’ve been playing D4.

I tested some older SD cards I have and the Ally will detect and allow me to browse their files, it only seems to have issues with my newer 512GB SANDISK which used to work without issue. 


Level 7

Same here, I just purchased a 1TB SanDisk microSDXC UHS-I card, and my Ally will not recognize it. It is able to detect my other smaller micro SD cards, but this card in particular will not be detected. The said card works fine on my PC. 

Level 7

I have the same problem, my sd card reader won't read any Sandisk mirco sd cards ( I tried 4 different ones)  but any other company's sd card works just  fine. All the sandisk cards work fine on my pc though a sd card reader.