cancel
Showing results for 
Search instead for 
Did you mean: 

ROG Ally not recognising 90W PD while connected to single USB-C 4K monitor with 90W PD support

fercabj
Level 7

I have a 4K monitor (Dell) with 90W PD through USB-C and I have a 100W capable USB-C cable (Belkin). And the Ally when I connect it to the monitor with that cable, the screen of the Ally turns off and the 4k monitor displays the screen. But the Ally is not charging at full speed and neither recognising that the power is more than enough to go to turbo mode (30W). The battery indicator shows an info icon that says that the Ally is NOT connected to a high wattage charger.

I have bought the ROG Ally 21 of November (and I have updated all drivers, armoury crate updates, Asus app updates, AMD updates and Windows updates).

For the record the Monitor model is Dell UltraSharp U2720Q 27" 4K USB-C Monitor , Up to 90W PD , IPS Panel HDMI+Display + USB-C Port. 

From the monitor manual here is the support: Dell PD 90 W descriptionDell PD 90 W description

Full manual link: Dell monitor Manual pdf

Anyone knows why this? Is this An issue or screen output and fast charge is not possible through this config?

Thanks in advance 🙂

1,070 Views
2 REPLIES 2

fercabj
Level 7

This is the message I'm getting, when connected to my monitor. Also I just realised that the Ally is showing Turbo mode as 30W. So I'm not sure what is going on there 🙂

info bubble while in 90W PDinfo bubble while in 90W PD

Anbby_ROG
Customer Service Agent

Hi @fercabj ,

This message is a reminder that, in order to ensure optimal performance for ALLY, it is recommended to use the included ASUS original power adapter. As we cannot guarantee the stability of third-party adapters/power banks for charging, using a non-original adapter may result in slow charging. In situations where gaming or high-load operations are involved, it may lead to a gradual decrease in battery levels, preventing effective charging. 

The provided information is for your reference. Thank you:)