Showing results for 
Search instead for 
Did you mean: 

ROG Ally - HDMI audio not (always) working

Level 9


I have run into an issue when connecting the Ally to my beamer (Acer v7500) via dock (Acefast) & HDMI cable: the video works flawlessly, but the sound keeps coming out through the Ally's speakers, not the sound system connected to the beamer. I also cannot see/select a different audio out in sound settings or device manager. It's like it doesn't exist. All windows, AMD, myAsus & armoury crate updates are done.

Now, before you ask: yes, the beamer and audio work when connected to the Shield or a laptop with HDMI. Also, when connecting the laptop through the Acefast dock & usb-c, everything is fine: PD charging, image & sound. Tried all possible sequences with the Ally (beamer first, on/off, Ally first, on/off etc) to no avail.

Finally, and here's the kicker: the Ally audio via HDMI did work fine! Once... Don't ask me how, buy when testing the Ally along the laptop (usb-c), it worked flawlessly. But only once. Didn't change or do anything, it just worked, but never after... Tried everything.

I therefore assume it's some software glitch or setting. Anybody else experienced this? And ideas? Thanks!


Customer Service Agent


Thank you for your feedback, because the equipment you use spans three different brands, there may be compatibility issues, it is recommended that you update the audio driver to the latest version, and please confirm the audio when connecting the HDMI Set whether there is an HDMI Audio device detected, and please keep the external projector firmware is the latest version of the vendor, and please change other C to HDMI accessories for cross-testing to confirm whether it is a compatibility problem. 

Troubleshooting - HDMI cannot output any sound



thank you.

Thanks for the feedback.

As said, all drivers are fully updated. Also, hdmi audio worked again one more time, but as soon as I restarted the Ally it disappeared again. It's gone from the device manager, I can see it if I choose to view inactive devices, but in its properties (acer v7500 hdmi audio) it will say it's not connected although it is. Can't figure out for the life of me why it works sometimes, and other times it doesn't. I tried everything I can think of in terms of restart, plug in first or after, turn on beamer etc etc. I don't see the pattern behind it.

Laptop with usb-c will work every time, same hardware, same Windows. Sorry but I won't buy another dock to test it out since this one seems to work just fine with other devices, and the Ally sometimes.

I don't get it.

I've been having the same issue.  Honestly thought It was a specific issue to the unit I had previously .   WIPE EVERYTHING, returned it, got a new one and it was working at first after I did all the updates, then it stopped working.   Now SOMETIMES it'll work ... I would say 1 of 10 times I plug it in it'll work... most other times it won't route the HDMI audio.   

I've gone into Device manager and looked at the HDMI Audio device and it shows the device is working but then if you go under events it says "Device not started" and " had a problem starting. "     

I don't know if that has anything to do with it or not.   

I have noticed that when it DOES work it shows the specific "SONY" or "SAMSUNG" under the device manager "monitors" .   Any time it doesn't work it just shows the tv screen as a "generic " monitor.    

I've purchased different HDMI cables, USB C Docks with PD etc.... still can't figure out how to make it work consistently.   My iPad, computer, and steam deck all work flawlessly with the set up.  I've tried 3 different tv's as well! 

Customer Service Agent

Sorry , I test all my HDMI device include portable monitor or desktop monitor, even ASUS beam projector, I can't reploduce your symptom. I try to find manual of ACER V7500, there is a setting related to HDMI CEC. Could you please turn it on and check again. Second, do you try both HDMI ports?

Level 9

I tried both HDMI ports, CEC on/off and various HDMI cables, no joy. 

On my Win11 Asus ROG Zephyrus S (gx531gx) it works flawlessly...

Level 8

I do have the same problem also. is there a fix now for this?

Not to my knowledge. I'm pushing sound via Bluetooth, but I shouldn't have to.

Tested different HDMI cables and a different screen, same outcome. All that's left now is the Acefast dock...and the Ally of course. Since the dock works fine fine my laptop (over USB-C), it seems obvious to me that the Ally is the culprit. Some issue talking to the dock. Weird...

I think it’s also a dock ally communication issue.     Someone brought up a point that the docks (even with 100W PD pass through) are not even getting the full 30W turbo mode.   One of the reps from ASUS said it was an issue they were working on.    I have a feeling it’ll get fixed with that same fix!   
There’s clearly some issues with the dock communication from the ally.  

Level 8

My issue was now resolve. I change my dock then boom. it all works on all my tv(with sounds) and monitors(up to 4k resolution) without issues. Some docks/hubs are not compatible with ally I think.