cancel
Showing results for 
Search instead for 
Did you mean: 

rog ally doesn't charge

aleasss
Level 7

Hi, my ally Just stopped to charge.

Now the battery it's 0% and It doesn't turn on and doesn't charge.

The Power supply work on others devices.

2,763 Views
5 REPLIES 5

Anbby_ROG
Customer Service Agent

Hi @aleasss ,

I'd like to confirm if you are using the original charger provided by the manufacturer. Have you tried using any other chargers before?
Could you please try pressing and holding the power button for 30 seconds, then reconnect the power and check if there is any response from the charging indicator light? Thank you for your cooperation.

Yes, i use the originale charger.

Now the ally it's dead because the battery it's 0% and If i Press the Power button nothing happen.

I tryed to keep press the Power button for 30 seconds, an than reconnect the Power supply, but nothing happen.

Anbby_ROG
Customer Service Agent

Hi @aleasss ,

I would like to confirm with you if there are any indicator lights when you connect the power supply? Have you tried using a different charger to see if it works? If the device still cannot power on, we recommend taking your Ally to the nearest authorized service center for further hardware diagnostics. We apologize for any inconvenience this may cause.

tuxedo25
Level 7

ive got the same problem as yours @aleasss did you fix your rog ally already?

I do too any luck @tuxedo25 @Anbby_ROG @aleasss