cancel
Showing results for 
Search instead for 
Did you mean: 

Rog ally BIOS 336 removes 3rd party docks support?

Alquala
Level 7

I have a problem since last update of my ROG Ally (Z1 extreme) to newest BIOS 336.

I use JSAUX dock station 6in1 with UGREEN Nexode 15337 100W charger. On previous version (335) when my ROG Ally was docked, I had 30W in Turbo mode. After BIOS update now in Turbo mode ROG Ally use only 25W. There is no way to boost it in manual mode in Armoury Crate.

I've tried to contact local ASUS support (Poland), but I got only answer that they support only "official configurations", even that support for 3rd party dock was added already in BIOS 323 ("Added 30W support when plugging in 65W or higher wattage PD adapters or Type-C hub").

Does anyone have an idea what went wrong? I didn't noticed on forums yet any reported issues from other people and I am not quite sure is this a individual problem? Any ideas what I can do in this situation?

1,166 Views
9 REPLIES 9

ranke90
Level 7

i test my jsaus 6in 1 dock and everything works fine with my ally

 

lilyjullet
Level 8

Since updating your ROG Ally to BIOS 336, you've noticed a decrease in power delivery when using the JSAUX dock station. ASUS enabled 30W support to BIOS 323, but the problem persists in Turbo mode after the latest update. To resolve this, consider contacting ASUS support again and providing information about the BIOS upgrade and the specific issue. If feasible, investigate internet forums to discover if others are experiencing similar issues or if there are any viable solutions. While you wait for an official solution from ASUS, it may be good to temporarily revert to the prior BIOS version.

Anbby_ROG
Customer Service Agent

Hi @Alquala @lilyjullet ,

Could you please record a video showing the situation where the charging is limited to 25W after connecting the charger? Additionally, could you provide the following information through private message to further assist you in resolving this issue? Thank you.

Serial Number:
BIOS version:
Windows Build Version: (Settings - System - About)
Dock brand/model:
Charger brand/model:
Is Dock connected to any other devices?

TheNewsPaper
Level 7

Did this issue fixed guys? I'm having the same problem limited Turbo limited to 25W

BIOS Ver 336

Alquala
Level 7

Ok. Problem solved. It seems that I’ve got this issue when new BIOS came up was a coincidence. After few experiments later suddenly my JSAUX dock stopped charging completely my Ally and the image was not transmitted via hdmi. So the problem was dock itself. I’ve returned it to the amazon and I bought now asus dock brick. Everything works fine now.

Thank you for the update. Seems I've to start a topic for mine. Since the dock is getting max power when connected to power bank. But the in box charger only gives the max power when connected directly to Rog not ally.

Anbby_ROG
Customer Service Agent

Hi @TheNewsPaper ,


I would like to confirm the wattage of the power bank you are using. If you are using a 65W power supply to charge both the dock and Ally, it might lead to insufficient power supply. I recommend using a 100W power supply for optimal performance. This information is provided for your reference.

Hi Abby 

Actually the power bank gives the max power and stable during the game play while in box charger charger don't. That why it's so weird. That happens when connected to the dock. So I believe there is no issues with the dock the problem seems with in box charger.

 

Thank you.

 

Anbby_ROG
Customer Service Agent

Hi @TheNewsPaper ,

Due to the power consumption of the dock, the supplied 65W charger from the original manufacturer achieves 30W turbo mode when only directly connected to Ally. If you wish to connect the dock and achieve 30W turbo mode with Ally, you will need to replace it with a 100W charger. 

You can refer to the charger brands shared by users in this discussion. Thank you.