cancel
Showing results for 
Search instead for 
Did you mean: 

Problem with MCU Firmware Update (RC71I)

NunaMoon
Level 8

Hi there,

I just got my Rog Ally and I tried to update the MCU Firmware 313 on Armoury but it's not really working. I keep on getting a pop up saying - "Firmware update tool the RC71l will be disabled for a few minutes during this time. Please keep your device plugged into a power source and do not turn it off until the update process is complete." Even after it says update completed, I still see that I need to update to this firmware on Armoury. There's a triangle with an exclamation inside it beside the download button.  I tried restarting, it didn't work..so i went ahead and did soft factory reset, but it still doesn't work. 

As well, i can't seem to change the resolution on my Rog Ally. It's greyed out, i'm not sure if this is bcs of the MCU Firmware that I wasn't able to get installed? Can someone pls help? 

Thank you!

6,830 Views
38 REPLIES 38

Anbby_ROG
Customer Service Agent

Hi @NunaMoon ,

Please try using the Uninstall Tool to remove Armoury Crate and then reinstall it. After reinstalling, please test if the update can be completed successfully.
If the issue persists, would you be able to enable the logging feature in Armoury Crate and then update the MCU Firmware to version 313 again? If possible, please record a video while doing this. This will greatly help us in understanding your problem better. Kindly send me the log files, the video, and your product's serial number via private message. I will forward this information to the relevant department for a quick resolution. Thank you for your cooperation.

【Here is the file path for the log file for your reference】
In Armoury Crate ""Settings"" and check ""About"" page, If clicking App Diagnostics ""Record Log"", the Privacy Policy Statement will pop out. Once user agreed statement, the Armoury Crate will start to collect problem log and you can click ""Generate log data"" to generate the log file with encrypted (ASUS log file).

Due to the ongoing regional holidays, my responses may be slightly delayed.
Thank you in advance for your patience.‌‌‌‌

Hi there,

I've just sent you a private message, hopefully you'll be able to help me out. thanks.

NunaMoon

Hi there, I am having the exact same issue, have you found a resolution for this?

No, not yet. 

Anbby_ROG
Customer Service Agent

Hi @Pintsizefrey  @Blackmachine76  @Lamia13  @Tokadusud 
Thank you for reporting this issue. To ensure that we address your concern accurately, as individual situations might vary, if you have already used the uninstallation tool to remove and reinstall ACSE but are still encountering the same problem, kindly enable the log recording feature in the toolbox. Afterward, please update the MCU firmware to version 313. This step will significantly assist us in better understanding your problem.

Kindly send me the log files, videos, screenshots of the 'System > About > Service Version - Check' screen, and the serial number of your product via private message. I will forward this information to the relevant department for a swift resolution. Thank you for your cooperation.


【Here is the file path for the log file for your reference】 
In Armoury Crate "Settings" and check "About" page, If clicking App Diagnostics "Record Log", the Privacy Policy Statement will pop out. Once user agreed statement, the Armoury Crate will start to collect problem log  and you can click "Generate log data" to generate the log file with encrypted (ASUS log file).

Due to the ongoing regional holidays, my responses may be slightly delayed.
Thank you in advance for your patience.‌‌‌‌

The error code from Armoury crate is : 4192

The Installation couldnt been done proprely !

Hope is gonna helps yall ! Pretty sur a mcu 314 will do ! 

Has there been any resolution to this I'm having the same issue  I've completely reset my ally and even have installed the file off ur site but it keeps asking me to install the 313 bios but I have  the newest the 323 it's just not registering to ur update software 

Blackmachine76
Level 7

Hi there, I am having the exact same issue too.

All the time reinstall RC71L  the version 313 but when i restard continue the same update.

any solution?

Did u find the answer as I'm having same issue