cancel
Showing results for 
Search instead for 
Did you mean: 

Problem with MCU Firmware Update (RC71I)

NunaMoon
Level 8

Hi there,

I just got my Rog Ally and I tried to update the MCU Firmware 313 on Armoury but it's not really working. I keep on getting a pop up saying - "Firmware update tool the RC71l will be disabled for a few minutes during this time. Please keep your device plugged into a power source and do not turn it off until the update process is complete." Even after it says update completed, I still see that I need to update to this firmware on Armoury. There's a triangle with an exclamation inside it beside the download button.  I tried restarting, it didn't work..so i went ahead and did soft factory reset, but it still doesn't work. 

As well, i can't seem to change the resolution on my Rog Ally. It's greyed out, i'm not sure if this is bcs of the MCU Firmware that I wasn't able to get installed? Can someone pls help? 

Thank you!

782 Views
38 REPLIES 38

I'm also having the same issue. I factory resetted my Asus Rog Ally (my current BIOS version is 330), I updated everything from MyAsus app, Windows Update and Windows Store, and I also uninstalled and installed Armoury Crate. The MCU Firmware is always showing the Install button enabled, and when I try to install the popup "Firmware update tool the RC71l will be disabled for a few minutes during this time(...)" appears and I confirm it and the popup executes its operation successfully, but the MCU Firmware still appears as to be update yet.
Here is a screenshot of the installation progress and where it does get stuck, and what happens after the popup concludes its execution.
ARMOURY CRATE SE 15_10_2023 13_01_00.jpgARMOURY CRATE SE 15_10_2023 13_01_25.jpg

Also, you mentioned to send you a private message with several attachments and logs, but I can't see how to do that in the toolbar...

Anbby_ROG
Customer Service Agent

Hi @marcofrosa ,

Due to the need for your personal information.
I have sent you a message, please check✉. Thank you

I’m also facing this problem with version 314. anybody also still facing the same issue?

Anbby_ROG
Customer Service Agent

Hi @JuNyAo84 ,

Regarding the MCU firmware update issue, it will be addressed in the next version of MCU Firmware 315. 
When you encounter this problem, please check if the MCU is up-to-date by going to Armoury Crate SE > Content Tab > System > About > Service Version > Check Button (RC71LM.314 / RC71LS.314).
If the displayed version number is correct, it means that MCU Firmware 314 has been successfully installed, and your device's functionality will not be affected. Only continue to receive update prompts in Armoury Crate SE.You can send your ALLY to the local service center for assistance with the update. If you are willing to wait, the next version, MCU 315, will address this issue.Thank you

Hey Anbby, Thanks alot so i guess MCU 315 will address this bug. As you said I have checked my service button and you are right i am currently on the latest firmware version ( RC71LM.314 / RC71LS.314 ) aura lighting also is on the latest 3.0.7 etc. i even cross checked it with the updater and all the numbers line up so my rog ally is on the latest verison. all its doing is to me and others is asking us to update our firmware but its already up to date, and i know what triggered this bug.

If you format your PC fresh copy of windows via USB stick it will trigger the bug as well as cloud recovery via BIOS.  what is happening is it keeps asking us to update our firmware but its already UpToDate 

Also any news on the BIOS 330 Coil Whine, its quite annoying. i hope you have a fix for it ASAP. 

adyojon
Level 10

Yes im having this problem also marco, i formatted my rog fresh copy of windows and it keeps asking me to get msu 314 but im already up to date. i also get a coil whine sound coming from my Rog after bios 330 this bios is no good. 323 was perfect no coil whine. i have contacted asus via PM, my support agent is amazing they actually want to help and fix the problems. thanks Anbby. 

adyojon
Level 10

M0rdresh
Level 7

I also have the same issue, it keeps telling my I need to update. When I click install it opens up the firmware install tool, runs then like 60% it pops to installed. But then Armoury Crate keeps telling me it needs installing. Uninstall tool and reinstall of the Amoury Crate does not help. I even ran the manual MCU update took of the support site.

uninstalling, formatting your PC does not fix this issue i tried this like 4 times. according to the MOD MCU 315 will fix this issue its a issue in the checker. 

i think i know how this bug happened, if you do a cloud recovery or format your pc and updated to MCU 314 and re install armory create it will bug out and keep telling you to get MCU 314 even tho you already have it.