cancel
Showing results for 
Search instead for 
Did you mean: 

My Asus Rog Ally doesn't update the MCU Firmware

Stefangamer1232
Level 7

I have bought an Asus Rog Ally three months ago and I did all the updates besides MCU Firmware because It  didn't work I am trying to update it everyday but still doesn't work,Can somebody help me?

321 Views
5 REPLIES 5

Anbby_ROG
Customer Service Agent

Hi @Stefangamer1232 ,


May I ask which version of the MCU firmware you are unable to update? Is there any specific error information related to this?
Have you tried performing a Cloud Recovery to see if it resolves the issue? Thank you.

Cloud Recovery in UEFI BIOS - Introduction | Official Support | ASUS Global

Cloud Recovery within MyASUS in WinRE - Introduction | Official Support | ASUS Global

Version 316 and I performed a cloud recovery and it doesn't works 

Anbby_ROG
Customer Service Agent

Hi @Stefangamer1232 ,

Please try updating the MCU to the latest version 317 through Armoury Crate SE and test it out. 

I'd like to confirm with you if there are any other abnormalities or error screens that we can further investigate. Thank you.

I tried updating to MCU 317 but it doesn't work 

IMG20240430085815.jpg

 And I should mention that command center button and armoury create button on Asus Rog Ally  don't work.

Anbby_ROG
Customer Service Agent

Hi @Stefangamer1232 ,

Thank you for your reply. Based on your description, we recommend that you bring ALLY to the local service center for further testing to confirm the issue. Thank you.