cancel
Showing results for 
Search instead for 
Did you mean: 

Failed to update to BIOS 331...

kaminari
Level 7

After rebooting the Ally, it can't enter bios. It always reboot to the windows interface.

Please help...

1,394 Views
4 REPLIES 4

Anbby_ROG
Customer Service Agent

Hi @kaminari ,

May I ask if you connected the power supply during the BIOS update? Have you tried testing it using the EZ Flash method?

If the issue persists, could you please provide any error screens or videos related to the problem? This would help us further investigate your issue. Thank you.

You can download the EZ Flash BIOS 331 file from here.

MastahKillah82
Level 8

I am having the same problem too. It will not update from 330 to 331.  It always says failed to install.  After downloading and installing the bios it tells me to restart> After restarting it just goes back to windows without installing the update.  I have it plugged in , I took out the micro sd card. I even turned off decryption and it still "fails to install".  Why is it so difficult to install this specific bios 331 ?

Anbby_ROG
Customer Service Agent

Hi @MastahKillah82 ,

Have you attempted updating BIOS 331 using EZ Flash ?
For instructions on updating with EZ Flash, you can refer to this link. Thank you.

I ended up getting it to work.  I had to download the driver and "extract" instead of installing.  Then I restarted the Ally while "holding down on the volume down button" until it went into the bios.  Then I had to manually find the "Drivers" folder where the bios file was extracted to.  It installed and finally worked.