cancel
Showing results for 
Search instead for 
Did you mean: 

Dell U2723QE monitor + Asus ROG Ally = ???

firles
Level 8

I have the Dell U2723QE monitor and the Asus ROG Ally, and they won’t talk to each other. 

Specifically, when I connect the two, the Ally screen goes black, the drives and other peripherals connected to the monitor light up, but the monitor display never gets a signal or shows a picture and the Ally screen stays black, and eventually the monitor displays a “no signal” type error  and goes to sleep. The Ally screen comes back on when I remove the USB-C plug.

The monitor works fine with my Mac laptop over USB-C, so it’s not the monitor being broken as an absolute matter. The Ally works fine with a different external display via USB-C, so it’s not the Ally USB-C or some Windows setting about displays being wrong as an absolute matter either.

I downloaded all software and drivers for the monitor for Win 11. I also used my Mac to update the firmware on the monitor. Still no dice.

Any ideas? Thanks!!

475 Views
8 REPLIES 8

BagelSoda3
Level 7

I'm having the same issue, the ally just doesn't want to talk with specific monitors recently, maybe an update?

alehel
Level 7

Exact same issue with my U3223QZ. Black screen, but all devices attached to dock (webcams, drives, speakers, etc) work. If I change from 60 to 30 hz I get a blue screen with some weird lines and artifacts, but still nothing that resembles my display. If I go to display manager the ally can definately see the screen and shows model name and supported resolutions correctly. Just doesn't manage to actually display anything on the display. My Ally just did a cloud restore, and I've updated the firmware of my monitor to the latest version. 

Anbby_ROG
Customer Service Agent

Hi @firles  @BagelSoda3  @alehel ,

Due to the need for your personal information.
I have sent you a message, please check✉. Thank you

firles
Level 8

Update. It works now, magically?

I plugged it into an Anker hub and then into the monitor. That worked. Somehow, magically, it now also works without the hub too, plugged directly into the monitor. The exact set up that did not work previously.

Anyone else fixed now? If so, it was likely.a software update. If not, I have a magic Anker hub we can trade around to fix it? LOL.

That's super weird 😅. I'm going to need you to post the hub name 🤣.

Anker 332

Not even a very expensive / rare part. Super weird is right. I assume it's a background software update that just generated a fun story though 😉

Yeah, fingers crossed it's an update. If it doesn't work for me in the next month I'll probably pick up a 332 with a desperate hope that solves it 😅.

Anbby_ROG
Customer Service Agent

Hi @firles @alehel ,

Thank you for the update. If there are any further assistance needed in the future, please feel free to let us know.