cancel
Showing results for 
Search instead for 
Did you mean: 

Dead ROG ally

sylgaming
Level 7

Hello,

I charged up my Rog ally after a gaming session and the day after I cant open it up anymore. When attached to a charging cable initially it is showing orange led light but doesnt open when I click the power button. Right now it is showing white led light when charged but still it doesnt open. No bootup, no sounds, nothing. I just had this device since last week of December. I tried the power hold and volume hold but it still doesnt work

258 Views
5 REPLIES 5

Anbby_ROG
Customer Service Agent

Hi @sylgaming ,
Please try removing all external devices and power, and long-press the power button for 30 seconds while the device is powered off. Then, reconnect the power and press the power button to boot up the system to see if you can enter it smoothly. Thank you.

I have done this and it didnt work. The charger is still working as i get indicator for orange when charging and white when it is full but the unit itself doesnt boot up. I tried bringing it to our service center in PH but sadly my unit is from US and they didnt accept it. 

Anbby_ROG
Customer Service Agent

Hi @sylgaming ,

I'm sorry, if your product is only covered by a warranty local to the United States, then indeed, you would need to send the device to the US for further repair and inspection. Thank you for your understanding.

Just as a random thought:

Unpluggin all devices and holding down the power button is a good test for devices not turning on to a certain extend.
In my personal experience, there is a higher chance of success when unpluggin the battery before, because of residual voltages.

Please note that I have absolutely no clue if this will void your warranty. In case of doubt, you should definitely contact the US Support first.

I have brought it to a 3rd party repair shop that actually is the one responsible of fixing the Ally's in my country. They have tried removing the battery and it still doesnt work. From the initial testing they have mentioned that one of the power "thingy" is grounded and needs to be repaired. I still dont know the reason how it ended up like this as I have only used the original charger of the device. Weird case in my end indeed. Will update this thread with the final diagnostics.