cancel
Showing results for 
Search instead for 
Did you mean: 

Armoury Crate freezing my ROG Ally

Joerpg84
Level 7

In the past, I realised having a large library of games would cause Armoury Crate to freeze and would have to force close it. This still allowed me to use my Ally. 

I fixed the freeze by cutting my games to ones that I need to use control configs changed. 

However…Ever since the windows update, and graphics driver issue last month…I have had lots of lagging problems. 

I thought I solved it but my issue now is that Armoury Crate will just freeze. I can’t do anything. I can open the command centre to restart my Ally. I try to open task manager by holding command centre and I click task manager but it won’t appear. It’s like the armoury crate just locks me from even ALT+F4 end task, even switching to desktop or use the windows bar on the bottom. It basically makes me have to restart windows. 

im not sure what’s causing this. I still have the RC71L AMD graphics driver update have a red dot on it in AC.

Before all this I had issues with games stuttering and freezing and uninstalled the windows update as suggested on reddit. MyASUS failed to install the latest Radeon Driver. I followed a guide to uninstall the driver in device manager and install it from a AMD extractor to C:AMD(I had to delete the folder first following the guide). This all failed to work and was worried messing with device manager as I’m not good with PC’s.

 I manually downloaded the Driver from a MyASUS link to install it and then repaired and reset AMD adrenaline app and it fixed my problem and was able to game without stutters. 

the only issue is when I start up my ally, the lower windows tool bar is missing and normally I swipe up for it to appear, but my ally has a black line and then pauses, the screen then goes black or flickers and then it works. It’s like maybe the graphics card is not functioning properly? Aside from that and the update in armoury crate saying to restart now for the new AMD driver never going away…I thought all was well. 

but now I have the Armoiry crate completely freezing my Ally unable to do anything but turn it off or restart windows. 

It seems like I have a complex amount of problems and unsure what to do. 

would appreciate any help. 

I plan on upgrading my SSD as my SD is full too but want to fix everything 

282 Views
2 REPLIES 2

Joerpg84
Level 7

 I have realised I have an error and it’s definitely my driver. 

The version of AMD Software that you have launched is not compatible with your currently installed AMD graphics driver.

 

IMG_9988.jpeg

For information on how to resolve this, please go to:

https://www.amd.com/en/support/kb/faq/pa-300

 

 

I went and rolled back the driver then AMD app worked. And its updated the driver in MyASUS again and fingers crossed this will fix this and the Armoury Crate locking up my ally. 

I still have the red dot for updating despite updating the graphics driver in MyASUS 

 

IMG_9906.jpeg

I also have the windows tool bar black screen flicker. I’m not sure if I should roll back the driver and not have this one installed? It seems like MyASUS says failed to install. 

 

Is there any windows updates I should uninstall? 
I heard this one was the problem (pic below) so don’t  have it installed but everything else is up to date. 

 

IMG_9989.jpeg

Anbby_ROG
Customer Service Agent

Hi @Joerpg84 ,

Please refer to the instructions at this link to remove the OpenCL™, OpenGL®, and Vulkan® Compatibility Pack. Please try uninstalling Armoury Crate SE using the uninstall tool, and then reinstall Armoury Crate SE to see if there is any improvement.

Regarding the AMD software, after updating to the new AMD driver version, please remove the AMD software and reinstall the latest version. We hope the above instructions are helpful to you.