cancel
Showing results for 
Search instead for 
Did you mean: 

Ally Stuck After Driver Update?

griffweeks
Level 7

I just updated the audio driver on my Ally, restarted my unit and now it loads to the initial screen that says Republic of Gaming, but then the screen goes black. Even if I attempt to access the BIOS menu, the screen remains black. Sometimes the backlight is on, sometimes it is off. The RGB for the sticks still lights up to the previous setting, but the screen itself doesn't show anything. I've made sure its at a reasonable temperature, tried every sort of combination of buttons to reset it, and I'm just kind of at a loss here. I'd even be open to a factory reset at this point, but I cant even access a menu to do that. Has anyone had a similar experience, and if so, how did you fix it?

214 Views
1 REPLY 1

Anbby_ROG
Customer Service Agent

Hi @griffweeks ,

I would like to confirm with you whether you have tried removing all external devices, including the power source, while the system is shut down. Afterward, please press and hold the power button for 30 seconds and then test to see if the system can start up successfully. Thank you.