cancel
Showing results for 
Search instead for 
Did you mean: 

Ally not detecting USB-C monitor

Virt
Level 7

I have a Samsung LS27A600U monitor and I try to connect it to the Ally using USB-C. Its gives power to the Ally and the USB ports on the back are connected, but no video signal. Windows says no display detected.

The monitor works, I used it with a mac and a windows 10 PC without issues. I even tried the same cable with the Ally.

I connected the Ally to an old dock and the dock to the monitor using HDMI and it works. But I wonder if my Ally is defective or there is some compatibility issue?

Btw, I also managed to get it work with a usb-c to displayport cable, so I guess DP works on my Ally to some extent.

1,618 Views
3 REPLIES 3

Alvez_ROG
Customer Service Agent

Hi Virt

   If you want to output signal directly , please make sure you use high speed USB 3.1 or 3.2 cable to avoid compatibility issue. 

Thank you for reaching us.

I used a USB 3.2 gen 2 cable.

Also tried the cable that came with the monitor (not sure specs) and a Thunderbolt 3 cable. Same results.

theadamp
Level 7

I have the exact same issue with my Dell U2723QE monitor. Updated monitor's firmware too. I also have a 32'' version of this monitor (U3223QE) which oddly works. Both monitors work fine with other devices on the same cable (and a few different ones). I have changed Rog Ally to a different unit but it still doesn't work. I will be returning that 2nd device tomorrow, I wanted to use this as a sort of gaming computer that I can also take on the road and continue gaming on. If I cannot game at home on a larger screen it's a dealbreaker for me.

I have contacted support but they weren't helpful too. They asked me the same set of questions over and over, asked me for a video for me connecting the monitor (which I did send and a few emails later they wanted more closeup shots of me connecting the cable or something). I guess they just wanted to tire me out which they did 🙂