cancel
Showing results for 
Search instead for 
Did you mean: 

Question about a Steam game

tarngmyna
Level 7

I just got the Asus ROG Ally 5-6 days ago. Most of the games work great from Steam. There’s been a couple where I had to mess around a bit. But got them working. For some reason the Laika Aged Through Blood demo I can’t get working. It worked great the first time. Tried again a couple days later. It’ll load up. But force closes at the startup logo screen and a message saying something about a Unity file comes up. Anyone have this issue? Know how to fix it?

108 Views
1 REPLY 1

Gany
Level 8

This is a common problem with demo packages that can be fixed by following a few simple steps.

Firstly, make sure that your computer meets the minimum system requirements for running the demo. This includes having a compatible operating system, graphics card, and enough RAM.

If your computer meets the requirements, then the problem may be with the Unity file that is causing the demo to crash. You can try deleting this file and re-downloading it from a trusted source. Alternatively, you can also try updating your Unity software to the latest version.

In some cases, conflicting programs or background processes may also cause game crashes. To avoid this, make sure to close all unnecessary programs before launching the demo.