cancel
Showing results for 
Search instead for 
Did you mean: 

Maximus XIII Hero & Oculus Link Not Recognised?

Lionhart27
Level 7
My previous Asus MB Maximus VIII Hero worked fine with the Oculus Quest 2 PC Link Cable. But since this new PC i9-11900K CPU and Maximus XIII, 32GB ram, RTX3090, the Oculus Link cable on the Quest 2 does not work, (USB Device Not Recognised) ? I have tried everything possible to get it to work, with loads of contacts with Oculus Tech and Asus Tech support. The USB Oculus Link does not work on ANY USB port. All drivers including USB drivers have been re-loaded , as have the Oculus software. I do have the Oculus Air Link, but this is not as good as the Link Cable, and the Oculus and VR Steam Home Screen will NOT load with the Air Link? If I had known this problem, before the purchase, I would have chosen another make of motherboard. Because the Oculus Link worked fine on the previous Asus MB, this must be something to do with the new MB or Asus/Intel USB drivers. I am very upset by this, as this problem has now been going on for months. ROG should stand for 'Rubbish Oculus Gaming'!
147 Views
0 REPLIES 0