cancel
Showing results for 
Search instead for 
Did you mean: 

FarCry 5 Crashes

dkulprit
Level 7
I'll post this here because it is a Rog Strix 1080ti gaming that is having the driver issue with the game and Nvidia forum members seem to be quite useless and give me gems like "if you're drivers are crashing, you need to find the cause and fix it."

Any help in troubleshooting this issue would be greatly appreciated.

I cannot go more than a couple minutes before the game crashes. looking in event viewer I am just getting a standard warning that the NVidia drivers have crashed. I have tried wiping drivers and everything that comes with it and reinstalling drivers all the way back to early December of last year. With earlier drivers I can play 5-10 minutes before it crashes, but the newest driver that is supposedly built to optimize Far Cry 5 barely a minute before it freezes and crashes.

MY PC:
i7-7700k at 4.8
asus maximus ix code
Asus strix 1080ti Gaming 11gb
EVGA Platinum 1000W
AOC 35" Agon 1440P
16GB Corsair Vengeance

I have tried everything from running at lowest graphic settings, turning VSync on, off, locking framereate and combinations between. Locking performance mode for power settings, locking the Geforce Experience power mode to "maximum Performance." Nothing works. I can't play this game. Game works if I use intel drivers and teh DP out on the mobo with no crashes.

I can play any other triple A title at ultra with no issue. But this game just does not want to work but I can't seem to find anyone else with this issue, it sold a lot of copies so if this were happening to everyone with a 1080ti there would be a lot of posts. Any ideas?

Thanks
8,274 Views
10 REPLIES 10

maraker
Level 7
I have idea. Are you using DDU with safe mode? Install only drivers and physx.
All hook and overlays are poison to farcry ,NFE is baaaad. Performance game drive version is stupid. 1-3 fps more in specifig game and lot of broken other stuff.

I run 388.71 my farcry 5. 385.x run it also when bypass version check. So why using buggy new driver.

because I was just trying different versions after the issue cropped up. I did not do safemode with ddu. I will give it a try. I did flash my gpu bios from the .023 to the .054 version and that seemed to help a lot. I could actually get stuff done, but experience is still installed, don't use any overlays but I could still see it as an issue.

Good luck. My desktop 1080ti and laptop 1080 works only fine if not install NFE and have to use ddu with safe mode. Also alk manufacture overrlock software are extream bad.

Nfe modify power mode and speed for gpu. That is main problem why it is crash some games. Without install it all it is fine. Nfe also collect performance data in your system and send that to nvidia. Aaargh. My both system temp with nfe is 75-85 gpu and cpu. Without nfe 60-62. And tested batlefront 2 ultra settings. Tested 385 388 391 brand . 391.x crash my games sometimes.

Using sli? Disable it.

Thanks!

No SLI. just a single GPU.

- First is to run Windows Update and install all the update available.
- Once done, do run SFC Scanner.
- Search for Command Prompt, right click on it and select Run as Administrator.
- Once open, type sfc/scannow then press Enter. While until it finish the scan and see if it will solve the issue or not.

- If the same problem will persist, do also run a memory test just to make sure everything is working properly.
- If all test will pass, last option would be to reinstall Windows 10.

Gofran wrote:
- First is to run Windows Update and install all the update available.
- Once done, do run SFC Scanner.
- Search for Command Prompt, right click on it and select Run as Administrator.
- Once open, type sfc/scannow then press Enter. While until it finish the scan and see if it will solve the issue or not.

- If the same problem will persist, do also run a memory test just to make sure everything is working properly.
- If all test will pass, last option would be to reinstall Windows 10.


Thanks! Will give this a try when I get home.

I had the same issue. Game was fine then after the latest nvidia update it was crashing every 10mins or so. Rolled back to previous driver and no more issues. My mate had same issue as well and we are both running rog strix 1080ti oc editions

Gofran
Level 8
dont know if you tried this but maybe try run 2 versions older version if not try to hard delete al file of nvidia with revo uninstaller maybe some file is keeping there i had this once with older gpu 980ti that i had