cancel
Showing results for 
Search instead for 
Did you mean: 

Cant play MWII on new build

Agent711
Level 8
Launching COD from battle.net app, COD MWII Season 2 window pops up, with ricochet anti-cheat in the upper right, the white bar at the bottom progresses completely but ends there. PC must be rebooted after every failed launch before any new attempt can be made because the .exe locks up and cant even be cleared from task manager. Black ops Cold War and every other game I have works fine. Worth noting that this is a brand new pc build, win 11 pro, I9-13900K, ROG Strix GTX 4090, ROG Maximus Z790 Extreme motherboard, 128gb ddr5. I have done all basic troubleshooting, disabled firewalls, added exceptions, reloaded the game, new drivers, old drivers, C++, all updates, different internet, everything I could think of before writing this didnt feel like a waste of time anymore. any advice is welcome

https://ibb.co/2yLSk4Y
1,693 Views
11 REPLIES 11

Silent_Scone
Super Moderator
Hello,

If the game is crashing to the desktop try disabling any overlays that might be running.
13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

Im never able to leave the desktop lol, the game never fully launches. Im wondering if its something conflicting with their new hardware based anti-cheat not liking the Maximus Extreme motherboard but its only a theory I concocted because im out of ideas

Silent_Scone
Super Moderator
The Anticheat puts a load on the CPU initially. I notice you're running 128gb. If you're using XMP, disable this and any additional overclocking and retest.
13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

it was set to auto, and disable isnt an option. I can choose Auto, Manual, XMP I, XMP II. All bios values are default, Im new to overclocking so I havent enabled anything yet. I planned to learn a little bit but didnt expect that I'd have issues so soon 😄 its weird that I only have the problem with this game

Agent711 wrote:
it was set to auto, and disable isnt an option. I can choose Auto, Manual, XMP I, XMP II. All bios values are default, Im new to overclocking so I havent enabled anything yet. I planned to learn a little bit but didnt expect that I'd have issues so soon 😄 its weird that I only have the problem with this game


Auto is stock and thus disables any overclocking.

It's going to be a software conflict you'll need to resolve on your side. Might have more luck posting on the MW2 sub reddit.
13900KS / 8000 CAS36 / ROG APEX Z790 / ROG TUF RTX 4090

that doesnt make sense but ill try it. I have 6 days to return these asus parts for something else so hopefully they help

Running 128 GB of DDR5 memory is a gamble. Could you do me a favour and run Memtest and then post the result? It's included in your bios, if it shows errors, then try to change the MC-Voltage at first and keep XMP disabled. It took me quite a bit of trial and error to run 128 GB of DDR5 stable.

It passed. Dropped it down to 64gb and that doesnt change anything

I just found the solution and I cant believe it. I had disabled microsoft one-drive and for whatever reason that caused my problem. After enabling it everything is working. Im still in shock but want to thank you both for your help.