Showing results for 
Search instead for 
Did you mean: 

Asus Zephyrus GX701 USB 3.1 Ports operating as USB 2.0

Level 7

I have a Asus Zephyrus GX701GX with a GTX 2080 Max-Q and 40GB of ram.

I've recently purchase a Quest 2 and trying to get Oculus Link to work. I have the official Oculus Link cable and my Laptop has 2x USB Type-C ports, one USB 3.1 and one USB 3.2.

Viewing my Quest 2 in the Oculus Desktop app says that I'm not connected through USB 3.0 and I've gone ahead and used a USB Scanning device called USBDeView that shows that the USB 3.1 connection through both Type-C ports are functioning as USB 2.1.

I've since tried the USB 3.1 Type-C cable that comes with the Quest 2, which also shows up as USB 2.1

Using another USB Type-C to Type-A cable works when connecting to one of my USB Type-A 3.0 ports

I've gone to my Device Manager > USB Serial Bus Controllers >

Intel(R) USB 3.1 eXtensible Host Controller 1.1 (Microsoft)
NVIDIA USB 3.10 eXtensible Host Controller 1.10 (Microsoft)

I've tried Updating them, Uninstalling and Reinstalling them, rebooting several times, etc

I've looked on asus support driver section for my model and I cannot find any dedicated USB drivers to attempt to reinstall

I've tried contacting Asus support, who barely has any support at all currently because of the outbreak.

The only response I've received trying to contact them by email is them telling me to format the computer and start over, which is horrible support.

I really would appreciate any help at all regarding this problem related to USB 3.1/3.2 type-c ports woirking as USB 2.0 ports.

I've found many instances of others having the same problem online but none of them with a solution. Everywhere I've gone has turned me down.

Please help 😞

Level 7
same issue with the computer and the solution. hoping to see someone chime in soon