cancel
Showing results for 
Search instead for 
Did you mean: 

Asus XG32VQ 144hz Freesync Screen Issue

Hooshieng
Level 7
Hi all, i just bought the ASUS XG32VQ 144hz freesync monitor last night. After install(HDMI+power cable) everything works fine. After that i tried to turn off screen and turn it on again but it cant. The screen prompt “HDMI No Input” and i tried to unplug and plug HDMI cable still cant turn on screen.(Note: when turn off screen i heard USB unplug sound, when turn on the screen heard plug in sound but no screen appear) May i know anyone facing this issue?*

My PC specs as below:
MSI GTX 970 4GB
INTEL I7 6700K 4.2Ghz
2 X 8GB DDR4 GSKILL RIPJAWS V (2 slot free)
CORSAIR H100i V2 WATER COOLED
ASUS ROG MAXIMUS VIII RANGER MOTHERBOARD
1TB WD HDD
SAMSUNG 2.5 850 EVO SSD 500GB
*SEASONIC 650W X-650 80PLUS GOLD PSU
2,895 Views
2 REPLIES 2

Fatal1tyBD
Level 7
Send it to RMA.

Korth
Level 14
Tried different HDMI ports, a different HDMI cable, and different HDMI signal source? And, of course, manually changing any signal/source select options the OSD might offer?

If the thing is apparently detecting stuff being plugged/unplugged in other ports then maybe check through them all - confirm there's no bent or broken pins, no jammed sensors/parts, no debris bridging electrical contacts, etc. The problem could be as simple as a bit of conductive packaging stuffed into your USB port.

If the product does appear defective and you "just bought" it then you should still be able to get an exchange or refund through the vendor.
Otherwise you'll have to go through ASUS and apply for an RMA ticket. This would be my last option, I hate shipping and delays and hidden costs and approval processes, etc.
"All opinions are not equal. Some are a very great deal more robust, sophisticated and well supported in logic and argument than others." - Douglas Adams

[/Korth]