cancel
Showing results for 
Search instead for 
Did you mean: 

1 month old ROG GL503GE turning off after 3 seconds after powering on. Symptoms

NilanganRay
Level 7
So, I am really pissed. I don't even use it much as I use my desktop PC. So, I did not use the laptop for 3-4 days and then I finally see the first issue day before yesterday.

Laptop stuck at 69% charge and showed "plugged in, not charging". And, it was also performing bit slower even at max performance setting. Slow bootup, slow response time.

I turned did some troubleshooting, and then turned it off and tried charging it. Same issue. LED would show but when I turn it on, it would say plugged in, not charging.

I kept it plugged. After like 30 minutes, I turned it on again, and I see that it charged upto 80% and was charging. And the performance also returned to normal. It was snappy like always. I thought , it might be a one time thing.

Did not use it yesterday, turned it on today (on battery) and I am seeing slow performance again. Battery at 98%. I suspect that it is happening again and I plug it in and again not charging. So I turn it off and then turn it on and it just turns off randomly while in desktop screen. Tried powering on, it will show the keyboard LEDs and then turn off.

A few times it would go to the loading screen and then turn off.

ASUS Support told me to turn it off and then quickly go to BIOS, which I do. It shuts off in the BIOS.

Definitely a hardware issue. Either something is heating which is resulting in the power cut off or there is something wrong with battery or PSU. I am devasted as its a new laptop. Hoping warranty claim is smooth. I am not sure how good it is in our area. Still it sucks that I will have to use a "repaired" laptop this early.


EDIT- Turning on again but still slow performance and not charging

Randomly switched off again.
7,894 Views
0 REPLIES 0