Showing results for 
Search instead for 
Did you mean: 

Strix RAID DLX, Control Box stops working - "nhAsusStrixSVC32.exe program error"

Level 9

Have had Asus Strix raid DLX for close to 9 years already. Last few weeks I got an error whenever i started up my Sonic Studio with the information:

Sonic Studio v.1.1.23
Sound Card FW v1.03
Control Box FW v1.14

"nhAsusStrixSvc32.exe Program Error
Instructions in 0x00000000774BF491 referred to the memory at the adress 0x0000000000EC1FB8. Memory could not be read.

Click Ok to terminate the program"

Link to the error picture:

If i click Yes, then the Strix Raid Control Box no longer responds/works whenever i click the physical "change input" key, nor the "Raid mode" button. However, if I just ignore the error message and let the window persist, then the Control Box will work as normal. The sound/microphone works as normally (plugged into the box) regardless, and I'm still able to change the output "digitally" by changing the output through the Sonic Studio menu.

Every time i re-open Sonic Studio, the error will re-occur within seconds.

I've tried to uninstall and re-install Sonic Studio. I've tried the Sonic Studio v1.1.22 as well. If i start the Control Box flash firmware the it will say error no control box found.

I run the latest Windows 10 Pro, 64-bit.
Version: 10.0.19045 Build 19045

Error also occurs when i run Windows in safe-mode..


Use WUMT to stop the automatic updates and choose what gets installed.

Unfortunately it seems I won't be using that control box anymore, but I really appreciate you taking the time to replying and sharing the updates you have installed.


I really wish we got a proper fix instead of "here's a beta driver, maybe Microsoft will fix it in the future, see you later". We shouldn't be forced to run an older, potentially more vulnerable OS.

Level 9

I've been using Asus for the past 20 years. Had the top of the line ROG products, every new gen i bought. I trusted Asus when I bought my 2 Strix Raid PRO instead of the Creative alternatives, to power my PCs. Now i have a nice paper weights. The driver is a bug mess, since 22h2. The control box, the thing i loved bout the cards? Useless. Asus response is to use a outdated OS or just give up. I did the last. Will be keeping it, as i don't want anyone to be this frustrated as i am owning these cards. Maybe one day, Asus wakes up and remember all the RAID buyers. As for now, will be buying my next platform, AM5, and will be going ASRock as main MOBO, and any other brand as 4XXX GPU. Done with Asus and its lack of respect with its loyal customers. Well done Asus, well f done.

They always do this, great products that get abandoned down the line. The devs probably WANT to fix it, but the resources never get allocated. It's really sad, but they already got the sale anyways, so joke's on us.

THIS! Its a shame it works this way. I do love Asus products, but the software support is just garbage. Will not be buying another Asus anytime soon...