cancel
Showing results for 
Search instead for 
Did you mean: 

Asus Xonar DX Trouble, I think she's gone, analog side anyway. Any advice?

jlsharbutt
Level 7
Hey all. I've been beating my head against the wall for some time about a supposedly superior product from Asus that was practically brand new.

One day I noticed I had no sound. I always used analog 7.1 with 3.5mm jacks. They all just quit working. I figured it was something simple, and I would just look in to it later. I think I ended up using onboard sound for the next year or two because I could never nail down a good resolution or fix. I know, I know, I should have RMAd it when I had the chance. Not possible now. I was trying to get ahold of an Asus rep for a couple of hourse today to see if we could work something out, but no fingers were crossed. Everyone I talked to wasn't qualified, per them, and had to transfer me to another unqualified rep.

Anyway, I have been loyal to Asus for as long as I can remember. I bet 75% of the tech in my office/game room came from them. I was disappointed when I couldn't get an answer on a simple audio card.

Have any of you all ever ran in to this, and is it possible it could be a quick fix or compatibility issue with onboard sound or digital devices?

I'm only typing this message as a last ditch effort to save myself a trip to town. Did love that Xonar when it worked.

Thanks,

Joey
346 Views
1 REPLY 1

Chrome_N
Level 9
Issue could be manifold of course. Let's check:
1) Card in a compatible slot? Did you connect the additional power jack?
2) Onboard soundcard disabled in the BIOS? Soundrivers for onboard sound uninstalled in Wndows Device Manager? (-> show disabled devices / uninstall)
3) Do you hear the relais clicking when booting the PC?
4) Tried the latest drivers from ASUS? Tried the UniXonar drivers?
5) Tried with different speakers / headphones?