Showing results for 
Search instead for 
Did you mean: 

Asus Strix Raid DLX & Win11 - controller not working

Level 8
Hi Everyone!

I've got here my Asus Strix Raid DLX sound card - the one with the external controller. It's running smoothly under Win10 64bit with the 1.1.23 drivers - I can control everything with the controller: Volume, Switch between headphone and Speaker... perfect.

Now I tried to upgrade to Win11 but there it doesn't work anymore. Then I tried a fresh install with the latest Win11 image from Microsoft - vanilla - installed nothing else but the same 1.1.23 drivers but the controller doesn't work: No Volume Changing and no switching between headphones & speaker.

Any ideas what to do? Other hidden drivers available? Patches?


Level 8
Asus is currently offering a workaround:

Level 8
Hi ArmedAssault!
First at all thanks for your link. I've seen quite few things in my web search but not that article.

- I ensured that I have the correct Win11 version running 22H2 (nothing comes up when trying Win Update).
- I've got several programs - no direct named "Sonic Studio". When I follow the SymLink on my Desktop I'm pushed to "ASUSTeKcomputer.Inc > nhAsusStrix > UserInterface
There are 3 Apps:

The SymLink Icon on my Desktop leads to the UILauncher. First I set the compatibility mode just for that to Win7 - without success. Then I setup the compatibility mode for all these 3 to Win7 but without any success as well. Still the same: Can't use the controller. 🤷*♂️

Level 8
The shortcut from the desktop leads to nhAsusStrixUILauncher.exe". Most likely, this process is meant.
ASUS has not released a working driver for Win 11 for more than a year. And I don’t think it will ever be released.

ArmedAssault wrote:
The shortcut from the desktop leads to nhAsusStrixUILauncher.exe". Most likely, this process is meant.
ASUS has not released a working driver for Win 11 for more than a year. And I don’t think it will ever be released.

Yes... I tried that one but didn't work for me. I'll try the other Win-modes as well. Really sad that there are no Win11 drivers for such an expensive product. Well.... if there is no other solution then probably have to switch to a competitors product 😞

Level 7

Asus müşterisini artık düşünmüyor. Bende artık onu düşünmeyeceğim.

Level 7

asus does not solve this, i tried everything you find on the net and nothing helped me, i even went back to an older version of w10 with no success. the driver still does not work properly or be recognized.
as i understand asus does not fix it they should release an update fixing the signature or certificates of some files or drivers as they have expired.
on computers that were working properly they are not affected by the problem as long as they do not change the operating system.

now i have a similar problem on an asus xonar u5 (sonic studio none of the audio enhancements work).

Asus definitely does a bad job on their devices that use sonic studio.

Level 9

I've been using Asus for the past 20 years. Had the top of the line ROG products, every new gen i bought. I trusted Asus when I bought my 2 Strix Raid PRO instead of the Creative alternatives, to power my PCs. Now i have a nice paper weights. The driver is a bug mess, since 22h2. The control box, the thing i loved bout the cards? Useless. Asus response is to use a outdated OS or just give up. I did the last. Will be keeping it, as i don't want anyone to be this frustrated as i am owning these cards. Maybe one day, Asus wakes up and remember all the RAID buyers. As for now, will be buying my next platform, AM5, and will be going ASRock as main MOBO, and any other brand as 4XXX GPU. Done with Asus and its lack of respect with its loyal customers. Well done Asus, well f done.

Level 7

Hi Space.

f you have not fond a cure for the problem of the volume controller not working under Windows 11 i was having the same problem in windows 10 and i was able to fix it by open the file properties for the launcher.exe file located in C:\Program Files\ASUSTeKcomputer.Inc\nhAsusStrix\UserInterface and changed the compatibility setting to run under windows 7 and restarted the computer . you may find that the controller still does not work however if you go back into the compatibility setting remove the tick mark to run under windows 7 and reboot again you might find that the controller now functions correctly as it did for me.

Hopes this works for you too.