cancel
Showing results for 
Search instead for 
Did you mean: 

ASUS Pheobus Solo stopped working

kj_tsu
Level 7
Few weeks ago I bought new PC platform (ASRock Z370 Extreme 4, i5 8600k, 16GB G.skill RAM), installed Windows 10 from scratch at SSD and base drivers required to run new PC. Downloaded Phoebus drivers and everything was working fine. Two days ago during conversation at discord app my sound turned off. I heard "click" sound and phoebus was dead. I rebooted PC, uninstalled drivers but when I tried to install them again I got "device not connected" or "card does not exist" message. Tried placing phoebus in different PCI-E slot, or even at another PC but result was the same. When card is plugged all LED's and diodes are lit so I don't think it's anything with power supply. Is this even possible for phoebus to stop working like that?
2,082 Views
2 REPLIES 2

Rewerend
Level 9
My phoebus died a year ago in a simialr way, I found cheap used one and bought it immediately, beacuse it´s hard to find some Phoebus in shops. It´s interresting that life of my phoebus wasn´t so long. How long did you used your card?

Same scenario here - bought used oned for new PC and I enjoyed it for 3 weeks... 😞