Showing results for 
Search instead for 
Did you mean: 

XT9 Nodes

Level 7


i just bought 3x this Set ->

so i have 6x XT9.

I connected the first one as AP and 3 with AiMesh. But with the last bopth I am not able to get a connection. Everytime I get a connection error. I do the same thing as with the other nodes.

Has anyone an idea?

WhatsApp Image 2023-05-19 at 22.43.43.jpegWhatsApp Image 2023-05-19 at 22.47.37.jpeg

WhatsApp Image 2023-05-19 at 22.48.14.jpeg

WhatsApp Image 2023-05-19 at 22.53.39.jpeg


Level 12

Did you try to add them 1 - 3 meters from the primary AP, via WiFi?

[Wireless Router] How to setup ZenWiFi AiMesh system (Web GUI)? | Official Support | ASUS USA

replace "AiMesh router" with "AiMesh AP" since you set up as AP...

ZenWiFi systems make your place covered with WiFi.It only takes a few steps for setup. ZenWiFi system offers easy and hassle-free management. ZenWiFi Overview AiMesh Overview To learn more about this video ...

Yes, I tried that first. Same result.

Hmm.  (I have 5 nodes, although not XT9, so it should work).

Have you tried turning off one node (1 of 3), replace with unlinked node, then try to add?

Yes, I have also tried that with the same result. I have also reset everything to factory settings and tried again from the beginning. Still no change. Even when I try to connect the non-functioning nodes first, I can see them, and I can see from the LEDs that something is happening, but then I get a connection error.

That sounds compelling that the nonfunctional ones are defective, (although 2 out of 6 is very high failure rate).  Out of 7 ASUS products I’ve owned one was defective, (1 of 7).

Amazon is very good at helping with defective products, (also ASUS but may take longer with them as they’ll likely try to troubleshoot some)…

Yes, thats what i do now. I send them back and order new ones.