Showing results for 
Search instead for 
Did you mean: 

TUF-AX5400 dual wan not working

Level 7

I recently bought a brand new TUF-AX5400 for my home setup, specially because the Dual Wan feature. But no matter how hard i try it doesn't work.

I have two ISP, both with their own routers that has DHCP enabled. if I plug any one into the WAN port, it assigns an IP and I can browse normally. The problem is when I try to use Dual Wan feature (WAN - Ethernet Lan), just the WAN works. I noticed this recently when ISP 1 was down and I was expecting that ISP 2 would take over and I could browser normally.

Checking then network map it shows a message "Your ISP's DHCP does not function properly.". It get stuck trying to receive a valid IP from ISP 2.  

I tried to factory reset couple times, router is algo using the latest firmware. I tried to switch between Load Balancer and Failover, I tried to switch ISP ports, mess around with WAN config. No luck.

I even tried an older router to simulate a secondary ISP, just check DHCP logs and it seems the ISP "router" assigns an IP, but TUF router does not read the given IP and get stuck on "Renewing".

Is this a bug from Asus router, like bad firmware version, or was I unlucky and bought  a defective model?

Any help is appreciated

screenshot 2023-08-13 às 16.43.43.pngscreencapture-asusrouter-Advanced-WAN-Content-asp-2023-08-13-16_43_13.pngscreencapture-asusrouter-Advanced-WAN-Content-asp-2023-08-13-16_42_48.pngscreenshot 2023-08-13 às 16.42.16.png


Level 13

EDIT-  I think you have the correct idea just try to turn the ISP routers to bridge mode or IP Passthrough.  Load balancing option may work better.,enable%20wh....

Level 12

I don't have a lot of experience with what you are doing, but I assume ISP 1 and ISP 2 are different service providers.  Certainly, not two connections from one provider.

Since your ISP 2 is not showing a WAN address, have you tried connecting it to the primary WAN input on your router to see if it works normally that way?  I am uncertain as to how a normal LAN port can request a WAN address, but that seems to be the way it should be configured.

Maximus Z790 Hero,
Intel i9-13900k
Intel AX411

If I connect ISP 2 to primary Wan it works as intended. I'm able to browse internet normally.

It is bonkers, regardless what ISP I use as primary it will work, but if I connect to LAN my asus router does not receive the IP correctly. 


Since LAN 2 would seem to be a valid port, perhaps your ISP can't deal with the LAN port at all, when using it as a WAN port. You might try LAN port 4 since it is used for the aggregation configuration.

It also looks like that router does not show an English version.  If you are international, that could certainly be related.

Maximus Z790 Hero,
Intel i9-13900k
Intel AX411

Moving to LAN4 didn't work either. I can see in ISP 2 logs that it  tries to give an IP to the asus router. 

Funny thing is, if I enable link WAN aggregation mode, the LAN4 works and I'm able to browser normally.   


But in the moment I change back to Dual WAN, it fails again.

LAN Link Aggregation or WAN Aggregation?  WAN Aggregation failovers automatically if one line goes down, if I’m not mistaken…

Level 13

My concern is that a lot of routers’ DHCP servers distribute the same LAN range of IP addresses.  If router from ISP #1 is distributing and router from ISP #2 is also distributing then you may have a situation where both routers have the exact same default gateway of .   I would assume the ASUS router would identify the secondary WAN DHCP server as not functioning properly if this were so.

An alternative to try is to change/confirm that the DHCP server of the 2nd ISP is not using the exact same Network ID: If ISP 1 is aaa.bbb.ccc ( then ISP 2 should be at least different aaa.bbb.ddd ( .

Well that was my first assumption, but all 3 routers are using different IP ranges.

  • ISP 1: 192.168.100.X
  • ISP 2: 192.169.1.X
  • Asus router: 192.168.50.X

I can see ISP 2 offering an IP to my asus router, but it seems it is not able to receive the address somehow. This message keeps showing constantly in my ISP 2 logs. 

[notice] <133>1 2023-08-15T09:19:50.203666-03:00 AONT dhcpd 18562 - -  DHCP-Comm:create_or_update_lease() XX:XX:XX:XX:XX:XX ip(201a8c0),portid=1, addrServPool default, lease=60. 
[notice] <133>1 2023-08-15T09:19:50.203781-03:00 AONT dhcpd 18562 - -  DHCP-Comm:sendOffer() sending OFFER of 
[notice] <133>1 2023-08-15T09:19:50.216651-03:00 AONT dhcpd 18562 - -  DHCP-Comm:dealRequestMessage() Deal Dhcp-DiscoveryMessage Success! DHCP request port-1, XX:XX:XX:XX:XX:XX RequestIP-0 XID-2317a29c 



I'm clueless what else I need to set up to make Dual WAN failover WAN - Ethernet Port 2 to work.

Level 13

The instructions I found on the ASUS website show that you can choose primary WAN to be a LAN port and secondary to be the WAN port, basically swapping the two.  Is this true and if so have you tried?  Which port works then?