Showing results for 
Search instead for 
Did you mean: 

RT-AX89X Remote Access Not Working

Level 7

Having an issue where I have remote access enabled and am unable to access it.

Initially when I set it up, I tested it and it worked fine. Was able to login from my cell browser from an external network.

I only tested it once though, and a couple weeks later (now) I wanted to remote into it to check something so I went to the subdomain that points to my router, got the login page, input my credentials, and it acted as if it was going to login, then immediately just went back to the login page. Tried a few more times, same scenario every time.

Tried from a computer, same thing.

Once I got home I rebooted my router in the off chance that it just decided to be weird. Still get the same issue.

Looking to see if anyone has experienced this before.


Level 13

Did you set up the DDNS or does your ISP provide for a static IP?

DDNS is setup and working, otherwise I wouldn't have even been able to get to the login page. Would have just errored out with Cloudflare otherwise.

That makes sense.

I think if the ISP provides a static IP address then DDNS is not necessary…

As a (hopefully) temporary workaround have you tried the ASUS Router app?

Level 7

Yes that would be correct but my ISP doesn't provide a static IP without asking, it's not really a big deal though, I've been using DDNS for a long time and never really had an issue.

The ASUS Router app doesn't even see my router and seems to require me to be on my local network for it to actually work.

The router should be accessible via the app basically anywhere once remote access is turned on, whether cellular or public/private WiFi, per my experience with other models.  (I don’t have a RT-AX89X I’m afraid).

Latest BIOS is 11 months old I wish other owners were on here/able to share their experience…


Community Admin
Community Admin

For discussions regarding ASUS products, please check out the networking section in ZenTalk. Thanks.

FPS, Racing, and VR Gamer / Tech Enthusiast / ROG Admin