Showing results for 
Search instead for 
Did you mean: 

RT-AX86U slow download speeds

Level 9

I've had this router for a little over two years and it has functioned perfectly until this last month. I have 2gig symmetrical fiber internet and when using the router's built in speed test, I was getting ~1,800mbps download and ~2,000mbps upload until mid-March. For the past couple of weeks, the speed test is showing ~400mbps download and ~2,000mbps upload. I have no idea why the download speeds are so slow. A technician from the internet provider stopped by and confirmed that the ONT is flashing a green light which means that the receiving client (my router) is sub gig. They connect the ONT to two different routers they brought with them and both of them were showing ~2,000mbps download speeds. So it has to be the router. Does anyone have suggestions on what I can do to troubleshoot this issue?

Some additional details:

  • The ONT is connected via Cat5E cable to the router's 2.5gb wan port.
  • The router firmware version is
  • I have tried rebooting the router and ONT.
  • I have not tried to factory reset the router.

Any updates?

Maximus Z790 Hero,
Intel i9-13900k
Intel BE200

Level 9

Here is what has occurred since my last update -- I bought a brand new router to see if that would also encounter the problem. It did. I would sometimes get advertised speeds, but most of the time the download speeds were far under what I am paying for. The internet provider is now seeing if this could be a problem on their side. I have a direct fiber connection with them, so I'm not totally sure how there is even a fluctuation on the download speeds. It doesn't seem to be an issue with my router.

If the technician mentioned something regarding a blinking green light, does it blink with this new router also?

Are you sure the WAN port on the Router is 2.5 Gbps?  I have wondered about this for a while.  The specs. show a 1 Gbe WAN port, but the 2.5/1G WAN\LAN can be confusing.  Newer routers have 10 Gbps WAN ports.

Maximus Z790 Hero,
Intel i9-13900k
Intel BE200

I have a RT-AX86U and it indeed has one of the configurable WAN/LAN 2.5 Gb Ethernet ports.  I have, at least on my GT-AXE11000, accidentally connected to a 1 GbE port by mistake.

@GW4C if you hover the mouse cursor over an Ethernet port sometimes a pop up shows which you can verify the link speed...


I'm reminded that this is why AT&T requires use of their Gateway.  Right now we aren't sure who's equipment is causing the trouble.....

I ended up going to the overview area of the router's administration page and it does show that the 2.5G wan port is connected and functioning as expected. What's really odd to me is that the upload speed is always 2gbps. It's perfect. It's only the download speed that is suffering. This occurs on both my old router and the brand new 86u pro that I bought. 

It's very early here, and I decided to run some speed tests.  My ASUS router and nodes are AP mode then nodes are AiMesh nodes.  The very first speed test netted a measly 277.x download speed so I went to my TP-Link BE95 (also AP mode), which was at typical 9yy Mbps.  So I went back to the ASUS which reached 9zz Mbps, BUT 12.a ms ping.  (Typical is ms range).

How's the ping?  (All this time I forgot to ask).

These are three speed tests I ran a few minutes ago. The upload speeds are always perfect. It's only the download speed that is the issue:

Discover the magic of the internet at Imgur, a community powered entertainment destination. Lift your spirits with funny jokes, trending memes, entertaining gifs, inspiring stories, viral videos, and so much more from users.

I am assuming you do not have two ethernet outputs from the Gateway so you can't try aggregating your speed?  I just can't think of any normal situation, that would cause what you are seeing.  Have you tried setting the QoS to see if it changes anything?  Even if you can bring it down, it might indicate it should be working correctly.

Sorry I was off, Spectrum is installing Fiber and cut my internet access off Thursday evening and I just got back.

Maximus Z790 Hero,
Intel i9-13900k
Intel BE200

Unfortunately not. The ONT only has one ethernet out. I have not attempted to turn on QOS on the old RT-AX86U or the new RT-AX86U Pro. It just seems odd that two different routers encounter the same issue. If it was a cable issue, wouldn't the download and upload speeds suffer? It feels like my ISP is capping the download speeds or they over provisioned and now they cannot support the full 2gig download speeds. But i don't see how that's possible either as they say that one benefit of fiber internet is that peak congestion hours doesn't affect my connection. I don't share my bandwidth with anyone else. It's a direct connection. 

Quick edit -- My other thought is that it could be the router firmware. Was considering loading an old firmware to see if it changes anything. Does anyone else have multi-gig internet and an RT-AX86U and can confirm that they receive full 2gig download?

I don't think the same wires are used for upload and download.  That said I am not sure it is symmetric, (even though I confess I have terminated Ethernet cables in the past).  A simple switching ends of the cable may reveal a bad cable by having the opposite slow speed on the upload side, but I did not research carefully enough to say confidently so.

I only have 1 Gig fiber I'm afraid.

@Saltgrass Did Spectrum offer you fiber service then/Did you switch?