Showing results for 
Search instead for 
Did you mean: 

RT-AX86U slow download speeds

Level 9

I've had this router for a little over two years and it has functioned perfectly until this last month. I have 2gig symmetrical fiber internet and when using the router's built in speed test, I was getting ~1,800mbps download and ~2,000mbps upload until mid-March. For the past couple of weeks, the speed test is showing ~400mbps download and ~2,000mbps upload. I have no idea why the download speeds are so slow. A technician from the internet provider stopped by and confirmed that the ONT is flashing a green light which means that the receiving client (my router) is sub gig. They connect the ONT to two different routers they brought with them and both of them were showing ~2,000mbps download speeds. So it has to be the router. Does anyone have suggestions on what I can do to troubleshoot this issue?

Some additional details:

  • The ONT is connected via Cat5E cable to the router's 2.5gb wan port.
  • The router firmware version is
  • I have tried rebooting the router and ONT.
  • I have not tried to factory reset the router.

Level 15

Well you already tried my first inclination which was reboot the router.  Can you replace the Cat5e cable with a better spec one, (I'm crossing my fingers).  

Level 9

I had considered replacing the cable, but the tech who came over today connected my cat5e cable to their own router and it pulled 2,000mbps download and upload without issue. So I feel like the cable is also fine. But I will honestly try anything at this point, so I'll get back to you after replacing the cable.

That's a good point that I failed to catch, that the fiber guy tried your cable.  It seems a factory reset is preferably avoided, (otherwise you would have tried it already).  I've seen on this forum strange things happen depending on order of rebooting, so I'm throwing this out there so to speak as a "worth a shot".  I like to turn on/reboot from outside in, meaning reboot the ONT, then (re)boot the router, but for fiber, (I forget what exactly happened doing it this way now, please excuse my memory as I age),  it was beneficial to (re)boot the router first, and while the router was ON reboot the ONT.  Did you happen to try the rebooting both ways?

I just rebooted the ONT first while the router was off, then once it was fully booted, I plugged in the router and unfortunately it's still showing slow speeds. 😞

Sorry, I was hoping you try the other way (also), while the router is ON just reboot the ONT...

That's not a bad idea actually. I may try that tomorrow and see if it works.

From the picture, which router do you actually have?

If it worked and now it doesn't, something had to change.  Could it be something like a firmware update or something you had done previously that was undone with an update?

The 86U has been noted in a couple of threads as to possible problems.  So, there may be some type of component failure.

There is also a possibility the ISP has put in place restrictions for third party routers.  Maybe they require some type of verification your device is allowed.  I know AT&T charges extra if you do not use their Gateway.  If you have a Gateway, can you check the speeds without the ASUS router?





Maximus Z790 Hero,
Intel i9-13900k
Intel BE200

Thanks for replying! I have the left most router (RT-AX86U). The tech did mention that I should have 2gig symmetrical on any router of my choosing, so hopefully that means that my account is not restricted. I don't currently have a gateway. I ended up ordering a new RT-AX86U Pro from Amazon a moment ago and it will be overnighted to my home tomorrow. We'll see if a new router solves it. The two routers that the tech used today (non-Asus routers) both gave 2gig symmetrical speeds with my same cat5e cable, so hopefully it's just a component failure.

While I hope your new router solves the problem satisfactorily I also hope that the RT-AX86U did not just fail right after the 2 year warranty went up.  (I actually have the same router, running as an AiMesh node.  Coincidentally just over two years old as well).

You very likely do not have AT&T service.  I asked the tech who installed our AT&T fiber:  "AT&T requires use of their gateway to help Quality Control their service?"  He agreed.  They do have capability to remotely access the gateways with your permission, (there's a place in the web GUI where you can turn on their ability to remote access into it.  This could have saved a tech visit I suspect for your case.  Sorry this is partly a response to @Saltgrass comment that AT&T would allow not using their gateway, which I am not aware of any option to, (fee or no fee).