Showing results for 
Search instead for 
Did you mean: 

RT-AX82U - Wireless Casting Issue

Level 7

Hi all,


I need some networking advice. I have a RT-AX82U which I recently set up (used to use an old AT&T router). For some reason, I can no longer use remote casting (Windows) to use my Surface Pro as a wireless monitor. I did not change anything else on my PC (Win 10) or the Surface Pro (Win 11), so I assume it must be a router setting. Chromecast works, as does Steam Big Picture, but I cannot figure out what is going on with the wireless monitor setup. 


Has anyone run into this before? Is there an obvious setting that could be causing this? I have not found a solution online. Any advice is welcome!



Level 13

You may want to share any error messages and some more details on what is going on.  Devices don’t see each other?  Device sees but won’t connect?  Connects but no pic/video?…

When I try to connect to a wireless monitor, neither can find the other (with my old router, they just showed up in Windows). I checked the Windows error log, and I did not see anything. I tried ping the laptop on my desktop, and they see each other. So basically, neither will show up as a wireless monitor (I tried it both ways). Both systems are up-to-date with Windows and drivers, and neither has any other technical issues that I can identify (connectivity to the network and web is fine).

I can see other advice when I try to connect (Bluetooth), and I tested Bluetooth connectivity on both (although not sure that matters here). Both work and are able to pair.

The router is on firmware The router log has this entry related (PC):
Aug 22 09:42:30 wlceventd: wlceventd_proc_event(539): eth5: Auth [PC MAC address], status: Successful (0), rssi:-69
Aug 22 09:42:30 wlceventd: wlceventd_proc_event(568): eth5: Assoc [PC MAC address], status: Successful (0), rssi:-69

It happened once, but nothing in the past 10 minutes.


They are not on a Guest Network, (I’ll assume not)?

Check the Advanced Settings - Wireless - Professional (tab) for a setting Set AP Isolated, make sure it is set to no.  Especially for the WiFi band they are both connected to, 2.4 or 5 GHz.


AP Isolated is off. And yeah, the first thing I checked was Guest Network. 😉

They were both on 2.4, but still nothing. 

I tried to connect my laptop to the surface pro, and that worked immediately! So, it is not the router. All I can think of is that something must have changed with a Windows update as I have not changed my network settings on the PC or the Surface Pro. 

The only other thing that just popped into my head right now is Windows has a setting to set a WiFi SSID as a Public or Home network, and that somehow switched from Home to Public when you swapped in the new ASUS router...

Community Admin
Community Admin

For discussions regarding ASUS products, please check out the networking section in ZenTalk. Thanks.

FPS, Racing, and VR Gamer / Tech Enthusiast / ROG Admin