Showing results for 
Search instead for 
Did you mean: 

RT-AC88U sometimes does not allow for my PC to connect to the network

Level 9
I've started having some weird things happen with my network a couple months ago. Sometimes when I get home, and turn on my PC, it will show that it does not have internet connection.

My PC (A) and PS4 (B) sit on a table across the room. When the above happens, both devices don't have network connection. They are connected to a small 5 port switcher. That switcher is connected to the RT_AC88U. All that is a wired connection. I have several other devices that are directly connected to the router via network cable. Those devices seem to be working normally.

I'll try to login to my router with my PC and it acts as if the cable is disconnected. The workaround is to ....

1. Turn off my RT-AC88U.
2. Disconnect all the network cables in back. I'm using 6 of the 8 wired ports in back.
3. Leave the cable that goes to my PC and PS4 connected. That in turn goes to a small 5 port switcher. Which connects to my PC and PS4.
4. Turn on the RT-AC88U.
5. The RT-AC88U will boot up.
6. Restart computer/or log out computer then back on. Then my PC can connect to the router and internet normally.
7. I plug back in the rest of the network cables in back. All the other devices connect normally.
8. All is fine for now.

But if I leave for the day. Then this issue may occur again.

Otherwise my internet connection, through my network works great.

Any suggestions as to how to fix this?

Level 9
There is another issue, that might be related to this, that affects my 2 PS4s connected to this same network. This morning when I noticed that my 2 PS4s were not showing that they were connected to the network. Physically they are connected with a wired connection. But when I use them they are not. When I check the client list on my RT-AC88U, they are not showing up.

The work around to get them connected is this.

1 - On the PS4, goto Network setup and choose Wireless.
2 - Go through the steps of attempting to connect.
3 - My wireless connections for 2.4Ghz and 5.0 Ghz are choices on my PS4 PRO, and just 2.4Ghz for my PS4.
4 - Both consoles attempt to connect wireless but are unable to. Normally they should be able to. Note: This is okay for this workaround.
5 - After getting failed messages on the previous step, change the PS4's connection in software to a Wired connection.
6 - Devices connect. Everything works well after this point.

I'll use my PS4s for a couple hours. Then either shut them down or put them in rest mode. It may be several days to several weeks before I use them again. If it's just a few days between usage, then they are likely to still be connected to my network when I use them again. If it's a longer duration, then they are likely to not be connected. And then I have to do the above steps to get it working again.

I got my router about 2 years ago. It worked awesome for most that time. But a few months ago, it started doing this. And then a few weeks ago it started doing the issue with my PC. We also noticed a couple weeks ago, that when a friend came by to connect their laptop wirelessly to one of our 2 wireless connections, that they can't connect to our network. Despite the 2 spots showing up. Running a wired connect allows them to connect. Our other phone devices seem to work normally. But I'm not sure if they lose wireless, and then use cellular to connect to the internet, or not.

Another friend of mine suggested to get a new router.

EDIT : I don't think I've tried a factroy reset of the router yet. I think I'll try doing that.

Level 9
I had seen some other posts elsewhere with similar issues. The suggestion on that was to revert the firmware to an earlier version. So I reverted the firmware to version That has a posted date of 20181205. December 12th, 2018. Today when I got home and booted things up, everything was connected. Which was nice. I was expecting some of my devices to not be connected. So was it reverting the firemware to an earlier state that fixed it? Or just some random luck that everything was connected when I booted up the devices? I dunno.